Bug 158483 - The backdrop-filter property does not respect border-radius
Summary: The backdrop-filter property does not respect border-radius
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Antoine Quint
URL:
Keywords: InRadar
: 158807 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-07 10:31 PDT by Antoine Quint
Modified: 2016-06-15 18:30 PDT (History)
6 users (show)

See Also:


Attachments
Testcase (600 bytes, text/html)
2016-06-07 10:33 PDT, Antoine Quint
no flags Details
Patch (40.66 KB, patch)
2016-06-07 16:47 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch (30.28 KB, patch)
2016-06-07 17:58 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff
Patch for landing (36.78 KB, patch)
2016-06-07 18:34 PDT, Antoine Quint
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Quint 2016-06-07 10:31:00 PDT
<rdar://problem/24210257>
Comment 1 Antoine Quint 2016-06-07 10:33:50 PDT
Created attachment 280720 [details]
Testcase
Comment 2 Antoine Quint 2016-06-07 16:47:59 PDT
Created attachment 280747 [details]
Patch
Comment 3 Simon Fraser (smfr) 2016-06-07 17:04:45 PDT
Comment on attachment 280747 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=280747&action=review

Code looks good but please use ref tests.

> Source/WebCore/platform/graphics/GraphicsLayer.h:381
> +    FloatRoundedRect backdropFiltersRect() const { return m_backdropFiltersRect; }

Return a const ref. These things are big.
Comment 4 Antoine Quint 2016-06-07 17:58:30 PDT
Created attachment 280752 [details]
Patch
Comment 5 Simon Fraser (smfr) 2016-06-07 18:05:04 PDT
Comment on attachment 280752 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=280752&action=review

> Source/WebCore/rendering/RenderLayerBacking.cpp:435
> +        LayoutRect boxRect = renderer.borderBoxRect();

Odd to fetch boxRect again, and alias the variable.

Better to use renderer().style().hasBorderRadius()

> LayoutTests/css3/filters/backdrop/backdrop-filter-with-border-radius-and-reflection-expected.html:2
> +    <meta name="viewport" content="width=device-width">

Pretty sure this does nothing in tests (unless you opt in to viewport stuff).
Comment 6 Antoine Quint 2016-06-07 18:34:44 PDT
Created attachment 280759 [details]
Patch for landing
Comment 7 WebKit Commit Bot 2016-06-07 19:06:07 PDT
Comment on attachment 280759 [details]
Patch for landing

Clearing flags on attachment: 280759

Committed r201785: <http://trac.webkit.org/changeset/201785>
Comment 8 WebKit Commit Bot 2016-06-07 19:06:11 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Ryan Haddad 2016-06-08 11:21:58 PDT
This change appears to have caused LayoutTest css3/filters/backdrop/dynamic-backdrop-filter-change.html to become much more flaky on Mac

http://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=css3%2Ffilters%2Fbackdrop%2Fdynamic-backdrop-filter-change.html
Comment 10 Antoine Quint 2016-06-15 18:30:36 PDT
*** Bug 158807 has been marked as a duplicate of this bug. ***