Bug 158079 - REGRESSION(r201040): Web Inspector: Completion popup does not update as you arrow through the list
Summary: REGRESSION(r201040): Web Inspector: Completion popup does not update as you a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: Safari Technology Preview
Hardware: All All
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords: InRadar
: 158165 (view as bug list)
Depends on: 157631
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-25 12:09 PDT by Timothy Hatcher
Modified: 2016-06-07 10:23 PDT (History)
14 users (show)

See Also:


Attachments
Video (999.05 KB, video/quicktime)
2016-05-25 12:09 PDT, Timothy Hatcher
no flags Details
[Animated GIF] Bug (77.74 KB, image/gif)
2016-05-25 14:34 PDT, Nikita Vasilyev
no flags Details
Patch (4.52 KB, patch)
2016-05-31 14:07 PDT, Dave Hyatt
zalan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2016-05-25 12:09:16 PDT
Created attachment 279789 [details]
Video

The completion text and the selected item are out of sync.
Comment 1 Nikita Vasilyev 2016-05-25 14:15:53 PDT
This is a regression. Looking into it.
Comment 2 Nikita Vasilyev 2016-05-25 14:31:41 PDT
Bisecting shows that it broke in http://trac.webkit.org/changeset/201040.
Comment 3 Nikita Vasilyev 2016-05-25 14:34:52 PDT
Created attachment 279814 [details]
[Animated GIF] Bug
Comment 4 BJ Burg 2016-05-27 07:18:58 PDT
Ping for import.
Comment 5 Joseph Pecoraro 2016-05-28 02:44:34 PDT
If its true that this is a regression caused by r201040 it describes itself as an optimization change, so maybe we should roll it out. Lets try to ping Hyatt first (+CC).
Comment 6 Radar WebKit Bug Importer 2016-05-28 02:45:25 PDT
<rdar://problem/26531703>
Comment 7 Dave Hyatt 2016-05-31 14:07:47 PDT
Created attachment 280182 [details]
Patch
Comment 8 Dave Hyatt 2016-05-31 14:56:42 PDT
Fixed in r201529.
Comment 9 Timothy Hatcher 2016-06-07 10:23:07 PDT
*** Bug 158165 has been marked as a duplicate of this bug. ***