Bug 15736 - REGRESSION (r19695-r19697): Overlapping table content on mtp.msnbc.com (Quirksmode)
Summary: REGRESSION (r19695-r19697): Overlapping table content on mtp.msnbc.com (Quirk...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.msnbc.msn.com/id/3032608/
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-10-28 11:41 PDT by David Kilzer (:ddkilzer)
Modified: 2013-07-22 10:23 PDT (History)
5 users (show)

See Also:


Attachments
Screenshot (48.32 KB, image/png)
2007-10-28 11:45 PDT, David Kilzer (:ddkilzer)
no flags Details
Partial reduction (depends on external resources) (1.97 KB, text/html)
2007-10-28 17:37 PDT, David Kilzer (:ddkilzer)
no flags Details
Reduction #1 (749 bytes, text/html)
2007-11-13 22:29 PST, David Kilzer (:ddkilzer)
no flags Details
Reduction #2 (300 bytes, text/html)
2007-11-13 22:31 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-10-28 11:41:41 PDT
* SUMMARY
The "TAKE TWO: msnbc.com" column in the right-center of the page has overlapping content in recent WebKit ToT builds.

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Go to URL:  http://www.msnbc.msn.com/id/3032608/
3. Look at "TAKE TWO: msnbc.com" column.

* RESULTS
The first item in the list overlaps the header image (see soon-to-be-attached screenshot).

* REGRESSION:
This is a regression from Safari 2.0.4 (419.3) with original WebKit on Mac OS X 10.4.10 (8R218).  Tested with a local debug build of WebKit r27112 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).
Comment 1 David Kilzer (:ddkilzer) 2007-10-28 11:45:36 PDT
Created attachment 16915 [details]
Screenshot
Comment 2 David Kilzer (:ddkilzer) 2007-10-28 12:31:23 PDT
Works: r19672  Fails: r19697

Comment 3 David Kilzer (:ddkilzer) 2007-10-28 12:53:11 PDT
Checking internal builds:
Works: r19695  Fails: r19698

Comment 4 David Kilzer (:ddkilzer) 2007-10-28 12:55:42 PDT
Almost certainly caused by r19696 as r19697 didn't change any table code:

http://trac.webkit.org/projects/webkit/changeset/19696

Comment 5 David Kilzer (:ddkilzer) 2007-10-28 17:37:12 PDT
Created attachment 16926 [details]
Partial reduction (depends on external resources)

A partial reduction (still depends on external resources).
Comment 6 mitz 2007-10-28 20:31:21 PDT
TOT matches Firefox on the reduction.
Comment 7 David Kilzer (:ddkilzer) 2007-10-28 21:23:45 PDT
(In reply to comment #6)
> TOT matches Firefox on the reduction.

Both Firefox 2.0.0.8 and Firefox 3.0a9pre (Oct 28, 2007) render the same was as ToT WebKit on Tiger.

Opera 9.22 renders like Safari 2.0.4 (419.3) on Tiger, as does MSIE 7 on Windows XP Pro.
Comment 8 David Kilzer (:ddkilzer) 2007-11-13 22:29:46 PST
Created attachment 17258 [details]
Reduction #1

This reduction is truer to the original page.

Works in Opera 9.22 and original Safari 2.0.4, but not in Firefox 2.0.0.9 or ToT WebKit + Safari 3 Public Beta.  On Tiger.
Comment 9 David Kilzer (:ddkilzer) 2007-11-13 22:31:26 PST
Created attachment 17259 [details]
Reduction #2

This reduction does not include a table, so it is not as true to the original page.

Renders as expected on Opera 9.22.  Overlap occurs on Safari 2.0.4, ToT WebKit+Safari 3 Public Beta and Firefox 2.0.0.9 on Tiger.
Comment 10 Robert Blaut 2008-02-01 14:22:50 PST
David, Opera renders both test cases as expected due to Quirks Mode: http://www.opera.com/docs/specs/doctype/ It emulates IE bug: 

"Vertical overflow in block elements with a specified height

In Quirks Mode, Opera will expand the block element to fit the content. In Standards Mode, Opera honours the height and applies the style overflow:visible if nothing else is specified."

If you add proper DOCTYPE to your test cases Opera will start render it as Webkit, Gecko in standards mode.

So we want to emulate above mentioned Opera behavior as well it should be added to Quirks Mode of Webkit. If we consider this bug in CSS standard way the bug is INVALID.
Comment 11 Robert Blaut 2008-02-01 14:27:18 PST
The overflow:visible issue is covered also on this page: http://www.quirksmode.org/css/quirksmode.html#t16
Comment 12 David Kilzer (:ddkilzer) 2008-02-02 09:42:44 PST
Thanks for the detective work, Robert!

Comment 13 Robert Blaut 2008-02-16 00:13:44 PST
The issue doesn't block bug 9610 which only tracks problems reported on this page: http://www.quirksmode.org/bugreports/archives/safari/
Comment 14 David Kilzer (:ddkilzer) 2008-02-17 09:19:53 PST
(In reply to comment #13)
> The issue doesn't block bug 9610 which only tracks problems reported on this
> page: http://www.quirksmode.org/bugreports/archives/safari/

Bug 9610 was a blocker due to Comment #10 and Comment #11.
Comment 15 David Kilzer (:ddkilzer) 2008-04-14 22:40:05 PDT
(In reply to comment #14)
> (In reply to comment #13)
> > The issue doesn't block bug 9610 which only tracks problems reported on this
> > page: http://www.quirksmode.org/bugreports/archives/safari/
> 
> Bug 9610 was a blocker due to Comment #10 and Comment #11.

Sorry, I misunderstood you Robert!

Comment 16 Robert Hogan 2013-07-22 10:23:41 PDT
This looks good now - closing..