Bug 157083 - Assertion failure for Reflect.get with Proxy and explicit receiver object
Summary: Assertion failure for Reflect.get with Proxy and explicit receiver object
Status: RESOLVED DUPLICATE of bug 157080
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Local Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-27 10:29 PDT by André Bargull
Modified: 2016-05-26 05:16 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description André Bargull 2016-04-27 10:29:16 PDT
SVN: rev200124
Build with: perl Tools/Scripts/build-jsc --gtk --debug


The following test case triggers this assertion error:
---
ASSERTION FAILED: prototype.isObject()
---


Test case:
---
Reflect.get(new Proxy({},{}), "x", {})
---


Stack trace:
---
#0  0x00007ffff6e289ac in WTFCrash () at ../../Source/WTF/wtf/Assertions.cpp:322
#1  0x00007ffff6cf22a7 in JSC::performProxyGet (exec=0x7fffffffcae0, thisValue=140736127155904, propertyName=...) at ../../Source/JavaScriptCore/runtime/ProxyObject.cpp:112
#2  0x00007ffff6cebb4e in JSC::PropertySlot::customGetter (this=0x7fffffffca80, exec=0x7fffffffcae0, propertyName=...) at ../../Source/JavaScriptCore/runtime/PropertySlot.cpp:39
#3  0x00000000004423b2 in JSC::PropertySlot::getValue (this=0x7fffffffca80, exec=0x7fffffffcae0, propertyName=...) at ../../Source/JavaScriptCore/runtime/PropertySlot.h:294
#4  0x0000000000448cfb in JSC::JSValue::get (this=0x7fffffffca40, exec=0x7fffffffcae0, propertyName=..., slot=...) at ../../Source/JavaScriptCore/runtime/JSCJSValueInlines.h:768
#5  0x00007ffff6cfc288 in JSC::reflectObjectGet (exec=0x7fffffffcae0) at ../../Source/JavaScriptCore/runtime/ReflectObject.cpp:181
#6  0x00007fffb0bff028 in ?? ()
#7  0x00007fffffffcb60 in ?? ()
#8  0x00007ffff6a33818 in llint_entry () from /home/andre/svn/webkit/WebKitBuild/Debug/lib/libjavascriptcoregtk-4.0.so.18
Backtrace stopped: frame did not save the PC
---
Comment 1 Yusuke Suzuki 2016-05-26 05:16:19 PDT
Fixed by 157080. Thanks for your reporting.

*** This bug has been marked as a duplicate of bug 157080 ***