Bug 156977 - Drop [UsePointersEvenForNonNullableObjectArguments] from EventTarget
Summary: Drop [UsePointersEvenForNonNullableObjectArguments] from EventTarget
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords:
: 156581 (view as bug list)
Depends on:
Blocks: 156844 156978
  Show dependency treegraph
 
Reported: 2016-04-25 08:03 PDT by youenn fablet
Modified: 2016-04-29 10:47 PDT (History)
6 users (show)

See Also:


Attachments
Patch (6.04 KB, patch)
2016-04-25 08:15 PDT, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2016-04-25 08:03:16 PDT
Drop [UsePointersEvenForNonNullableObjectArguments] from EventTarget
Comment 1 youenn fablet 2016-04-25 08:15:34 PDT
Created attachment 277250 [details]
Patch
Comment 2 youenn fablet 2016-04-25 08:16:46 PDT
(In reply to comment #1)
> Created attachment 277250 [details]
> Patch

Patch is not fixing yet dispatchEvent as it requires changing Objc and GObj binding generator.
Comment 3 Chris Dumez 2016-04-25 09:54:51 PDT
Comment on attachment 277250 [details]
Patch

r=me
Comment 4 WebKit Commit Bot 2016-04-26 06:02:48 PDT
Comment on attachment 277250 [details]
Patch

Clearing flags on attachment: 277250

Committed r200078: <http://trac.webkit.org/changeset/200078>
Comment 5 WebKit Commit Bot 2016-04-26 06:02:53 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Darin Adler 2016-04-29 10:47:56 PDT
*** Bug 156581 has been marked as a duplicate of this bug. ***