Bug 156581 - Remove UsePointersEvenForNonNullableObjectArguments from Node and EventTarget
Summary: Remove UsePointersEvenForNonNullableObjectArguments from Node and EventTarget
Status: RESOLVED DUPLICATE of bug 156977
Alias: None
Product: WebKit
Classification: Unclassified
Component: Bindings (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-14 09:22 PDT by Darin Adler
Modified: 2016-04-29 10:48 PDT (History)
2 users (show)

See Also:


Attachments
Patch (68.88 KB, patch)
2016-04-14 09:31 PDT, Darin Adler
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-yosemite (941.68 KB, application/zip)
2016-04-14 10:27 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews106 for mac-yosemite-wk2 (787.77 KB, application/zip)
2016-04-14 10:32 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews112 for mac-yosemite (869.16 KB, application/zip)
2016-04-14 11:03 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2016-04-14 09:22:16 PDT
Remove UsePointersEvenForNonNullableObjectArguments from Node and EventTarget
Comment 1 Darin Adler 2016-04-14 09:31:53 PDT
Created attachment 276399 [details]
Patch
Comment 2 Build Bot 2016-04-14 10:27:37 PDT
Comment on attachment 276399 [details]
Patch

Attachment 276399 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/1156693

New failing tests:
dom/xhtml/level3/core/nodegetbaseuri02.xhtml
inspector/dom/setOuterHTML.html
js/dom/dom-static-property-for-in-iteration.html
Comment 3 Build Bot 2016-04-14 10:27:38 PDT
Created attachment 276401 [details]
Archive of layout-test-results from ews102 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews102  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 4 Build Bot 2016-04-14 10:32:06 PDT
Comment on attachment 276399 [details]
Patch

Attachment 276399 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/1156704

New failing tests:
dom/xhtml/level3/core/nodegetbaseuri02.xhtml
inspector/dom/setOuterHTML.html
js/dom/dom-static-property-for-in-iteration.html
Comment 5 Build Bot 2016-04-14 10:32:08 PDT
Created attachment 276402 [details]
Archive of layout-test-results from ews106 for mac-yosemite-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-yosemite-wk2  Platform: Mac OS X 10.10.5
Comment 6 Build Bot 2016-04-14 11:03:30 PDT
Comment on attachment 276399 [details]
Patch

Attachment 276399 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/1156824

New failing tests:
dom/xhtml/level3/core/nodegetbaseuri02.xhtml
inspector/dom/setOuterHTML.html
js/dom/dom-static-property-for-in-iteration.html
Comment 7 Build Bot 2016-04-14 11:03:33 PDT
Created attachment 276406 [details]
Archive of layout-test-results from ews112 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews112  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 8 Darin Adler 2016-04-29 10:47:56 PDT

*** This bug has been marked as a duplicate of bug 156977 ***
Comment 9 Darin Adler 2016-04-29 10:48:32 PDT
Youenn already took care of this.