Bug 15516 - Inspector hangs in Position::isRenderedText() inspecting this file
Summary: Inspector hangs in Position::isRenderedText() inspecting this file
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.carto.net/neumann/cartogra...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-10-14 23:43 PDT by Eric Seidel (no email)
Modified: 2012-06-26 00:35 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-10-14 23:43:38 PDT
Inspector hangs in Position::isRenderedText() inspecting this file

I tried inspecting:
http://www.carto.net/neumann/cartography/papermaps/japan.svgz

with the inspector.  Trying to toggle the discloser triangle on the root <svg> element hangs Safari in Position::isRenderedText() (or rather the shark sample shows us spending all our time there.  I'm not sure if this is an inspector issue or an editing code issue.  I think it's an editing code issue.  It looks like each call for next() ends up walking the linebox tree if your current position is in a block, but I'm not really sure.  I'm not really sure I understand the position code well enough to provide helpful commentary.

I'll attach a shark sample in a sec.
Comment 1 Eric Seidel (no email) 2007-10-14 23:47:07 PDT
	5.6%	21.5%	WebCore	WebCore::Position::inRenderedText() const	
	0.0%	21.5%	WebCore	WebCore::PositionIterator::isCandidate() const	
	0.0%	21.5%	WebCore	WebCore::nextCandidate(WebCore::Position const&)	
	0.0%	21.5%	WebCore	WebCore::VisiblePosition::canonicalPosition(WebCore::Position const&)	
	0.0%	21.5%	WebCore	WebCore::VisiblePosition::init(WebCore::Position const&, WebCore::EAffinity)	
	0.0%	21.5%	WebCore	WebCore::VisiblePosition::VisiblePosition[in-charge](WebCore::Node*, int, WebCore::EAffinity)	
	0.0%	21.5%	WebCore	WebCore::RenderText::positionForCoordinates(int, int)	
	0.0%	21.5%	WebCore	WebCore::RenderBlock::positionForCoordinates(int, int)	
	0.0%	21.5%	WebCore	WebCore::RenderObject::positionForPoint(WebCore::IntPoint const&)	
	0.0%	21.5%	WebCore	WebCore::EventHandler::handleMousePressEventSingleClick(WebCore::MouseEventWithHitTestResults const&)	
	0.0%	21.5%	WebCore	WebCore::EventHandler::handleMousePressEvent(WebCore::MouseEventWithHitTestResults const&)	
	0.0%	21.5%	WebCore	WebCore::EventHandler::handleMousePressEvent(WebCore::PlatformMouseEvent const&)	
	0.0%	21.5%	WebCore	WebCore::EventHandler::mouseDown(NSEvent*)	
	0.0%	21.5%	WebKit	-[WebHTMLView mouseDown:]	
	0.0%	21.5%	AppKit	-[NSWindow sendEvent:]	

Comment 2 Elliott Sprehn 2012-06-26 00:35:01 PDT
This doesn't reproduce anymore.