Bug 15401 - Myspace login failure
Summary: Myspace login failure
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://myspace.com
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-06 10:38 PDT by Misty Willows
Modified: 2010-01-02 09:51 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Misty Willows 2007-10-06 10:38:56 PDT
When I attempt to login to myspace.com, I get returned to the login sceen with the error message. "You must be logged in to do that".    I have tried clearing my cookies and my cache, but the error persists.  I don't get this error with the official Safari
Comment 1 Matt Lilek 2007-10-06 11:08:05 PDT
(In reply to comment #0)
> When I attempt to login to myspace.com, I get returned to the login sceen with
> the error message. "You must be logged in to do that".    I have tried clearing
> my cookies and my cache, but the error persists.  I don't get this error with
> the official Safari
> 

What version is "official Safari" (Safari 2 or are you using the v3 Beta) and what nightly are you testing with?  I get that message in ToT, Safari 3.0.3 Beta and Safari 2.0.4 with the following spit to the console:

Unsafe JavaScript attempt to access frame with URL http://www.myspace.com/ from frame with URL http://deEB.myspace.com/html.ng/site=myspace&position=east&page=10000000&rand=770825951&acnt=2&schoolpage=0. Domains, protocols and ports must match.

Finally, are we sure this is even a bug and not just Safari doing humanity a favor? :)
Comment 2 David Kilzer (:ddkilzer) 2007-10-06 12:28:08 PDT
I am able to log into my myspace.com account (without the console message in Comment #1) using a local debug build of WebKit r26074 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

Are you going directly to http://www.myspace.com/, or hitting another URL first?
Comment 3 Misty Willows 2007-10-07 01:27:10 PDT
(In reply to comment #1)
> (In reply to comment #0)

> What version is "official Safari" (Safari 2 or are you using the v3 Beta) and
> what nightly are you testing with?  
Safari Version 2.0.4 (419.3) worked normally for me.
Webkit build r26067  is the build I reported the bug with, but I also get it with r26075

((In reply to comment #2)

> Are you going directly to http://www.myspace.com/, or hitting another URL
> first?
I am going Directly to http://www.myspace.com/

Comment 4 David Kilzer (:ddkilzer) 2007-10-07 17:41:49 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Are you going directly to http://www.myspace.com/, or hitting another URL
> > first?
> I am going Directly to http://www.myspace.com/

Are you testing a beta feature of myspace.com or something like a school-themed page (in which the login process might differ)?  Do any of your friends have this issue with Safari Nightly builds?

Comment 5 Misty Willows 2007-10-07 22:05:34 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > > Are you going directly to http://www.myspace.com/, or hitting another URL
> > > first?
> > I am going Directly to http://www.myspace.com/
> 
> Are you testing a beta feature of myspace.com or something like a school-themed
> page (in which the login process might differ)?  Do any of your friends have
> this issue with Safari Nightly builds?
> 
I'm not testing any beta feature or using a themed page. I'm using the standard login form on the stasndard myspace home page.

I don't know anyone else testing nightly builds so i don't know if anyone else is experienceing this bug. 

Comment 6 David Kilzer (:ddkilzer) 2007-10-08 08:07:13 PDT
(In reply to comment #5)
> I'm not testing any beta feature or using a themed page. I'm using the standard
> login form on the stasndard myspace home page.

Okay, I was able to reproduce these console error messages by clearing ALL of my *.myspace.com cookies in Safari:

Unsafe JavaScript attempt to access frame with URL http://www.myspace.com/ from frame with URL http://deEB.myspace.com/html.ng/site=myspace&position=east&page=10000000&rand=567926893&acnt=2&schoolpage=0. Domains, protocols and ports must match.

However, I was still able to log in.  The only difference was that myspace.com showed some kind of "nag" screen about themes before taking me to my home page.  I had to click on a link in the upper right-hand corner of the screen that said "Skip this Advertisement >>".
Comment 7 Misty Willows 2007-10-08 18:05:23 PDT
I was able to log in using WebKit r26103. Did anyone do anything to fix this, or was it serendipity?
Comment 8 David Kilzer (:ddkilzer) 2007-10-08 18:15:07 PDT
(In reply to comment #7)
> I was able to log in using WebKit r26103. Did anyone do anything to fix this,
> or was it serendipity?

Try using an older nightly build to see if it works now.  Myspace.com could have made changes to their site, or it may just be serendipity.

I don't see any changes between r26075 and r26103 that would have "fixed" this issue.

Comment 9 Adam Barth 2010-01-02 09:51:41 PST
The reporter notes above that the issue is fixed.  This bug hasn't been touched in years.