Bug 153956 - REGRESSION(r196222): [AX][GTK] accessibility/gtk/caret-offsets.html failing
Summary: REGRESSION(r196222): [AX][GTK] accessibility/gtk/caret-offsets.html failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: Other
Hardware: PC Linux
: P2 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2016-02-06 18:16 PST by Michael Catanzaro
Modified: 2016-05-07 06:03 PDT (History)
8 users (show)

See Also:


Attachments
Patch (11.12 KB, patch)
2016-05-06 17:16 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2016-02-06 18:16:12 PST
accessibility/gtk/caret-offsets.html is failing since r196222:

--- /home/slave/webkitgtk/gtk-linux-64-release-tests/build/layout-test-results/accessibility/gtk/caret-offsets-expected.txt
+++ /home/slave/webkitgtk/gtk-linux-64-release-tests/build/layout-test-results/accessibility/gtk/caret-offsets-actual.txt
@@ -23,7 +23,7 @@
 PASS caretMovedData is "Heading|5"
 PASS caretMovedData is "Paragraph|5"
 PASS caretMovedData is "Paragraph|20"
-PASS caretMovedData is "Paragraph|30"
+FAIL caretMovedData should be Paragraph|30. Was .
 PASS setCaretOffset(link, 5) is true
 PASS caretMovedData is "Paragraph|17"
 PASS list.role is "AXRole: AXList"
@@ -41,7 +41,7 @@
 PASS table.childrenCount is 1
 PASS row.role is "AXRole: AXRow"
 PASS tableCell.role is "AXRole: AXCell"
-PASS caretMovedData is "Cell|2"
+FAIL caretMovedData should be Cell|2. Was .
 PASS successfullyParsed is true
 
 TEST COMPLETE

https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20(Tests)/r196222%20(13632)/results.html
Comment 1 Radar WebKit Bug Importer 2016-02-06 18:16:29 PST
<rdar://problem/24540768>
Comment 2 Radar WebKit Bug Importer 2016-02-06 18:16:48 PST
<rdar://problem/24540769>
Comment 3 Joanmarie Diggs (irc: joanie) 2016-05-06 17:16:02 PDT
Created attachment 278295 [details]
Patch
Comment 4 WebKit Commit Bot 2016-05-07 06:03:15 PDT
Comment on attachment 278295 [details]
Patch

Clearing flags on attachment: 278295

Committed r200542: <http://trac.webkit.org/changeset/200542>
Comment 5 WebKit Commit Bot 2016-05-07 06:03:19 PDT
All reviewed patches have been landed.  Closing bug.