Bug 15336 - Tracking a crasher with proxy usage (ssh -D) socks
Summary: Tracking a crasher with proxy usage (ssh -D) socks
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://aws.amazon.com (account activity)
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-10-01 15:39 PDT by William Coldwell
Modified: 2007-10-05 18:32 PDT (History)
2 users (show)

See Also:


Attachments
crash report (20.71 KB, text/plain)
2007-10-05 16:26 PDT, William Coldwell
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Coldwell 2007-10-01 15:39:19 PDT
Certain websites are crashing Safari at the end of rendering a page, but only when used through a tunnel (haven't been able to test VPN, just ssh -D socks).

Currently searching for a smaller test case.
Comment 1 mitz 2007-10-01 16:03:05 PDT
Please attach a recent crash report.
Comment 2 Mark Rowe (bdash) 2007-10-01 17:55:27 PDT
I'm 90% sure this will be due to a bug in CFNetwork that leads to a crash when visiting HTTPS sites over a SOCKS proxy.  Please post a crash log so that this can be verified.
Comment 3 William Coldwell 2007-10-01 21:46:50 PDT
Thread 3 Crashed:
0   <<00000000>> 	0xffff8c74 __memcpy + 1236 (cpu_capabilities.h:189)
1   com.apple.CFNetwork            	0x90fae204 _PerformSOCKSv5PostambleHandshake_NoLock + 1224

looks like bdash is on the money.  The sites that trigger are https.

It's been here for a while, since I was hitting it but assuming that it was webkit growing pains.
Comment 4 Mark Rowe (bdash) 2007-10-01 22:02:44 PDT
Is that when viewing an https:// site?  Can you attach the full crash log entry please?
Comment 5 William Coldwell 2007-10-05 16:26:05 PDT
Created attachment 16554 [details]
crash report

This is created by going to https://www.juniper.com
However, I noticed that going to https://www.warped.com won't trigger it.
The Amazon S3 page would only make it crash after the page was rendered, or at least most of it.

I can duplicate this 100% on either PPC or x86 with 10.4.10 (haven't tried leopard yet).

My configuration is ssh -D 12345 somemachinewithsshd.warped.com and with Network configuration set to Proxy Socks 5 on 127.0.0.1 port 12345.

This does not happen with Camino or Firefox, but does happen on Safari, WebKit nightly, and OmniWeb (sneakypeek).
Comment 6 Mark Rowe (bdash) 2007-10-05 18:32:47 PDT
As mentioned, this is not a bug in WebKit but in the underlying CFNetwork framework.  It is tracked in radar as <rdar://problem/4323043>.  I'll close this bug as invalid as it has nothing to do with WebKit.