Bug 152409 - Web Inspector: Remove "local" scope type from the protocol
Summary: Web Inspector: Remove "local" scope type from the protocol
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Joseph Pecoraro
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-17 17:19 PST by Joseph Pecoraro
Modified: 2015-12-17 20:18 PST (History)
12 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (6.53 KB, patch)
2015-12-17 17:21 PST, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2015-12-17 17:19:13 PST
* SUMMARY
Remove "local" scope from the protocol.

After r194251, it is no longer sent from the backend to the frontend. The frontend should be able to determine was is "local" to the current selected call frame or not. Do that in a follow-up.
Comment 1 Joseph Pecoraro 2015-12-17 17:21:47 PST
Created attachment 267599 [details]
[PATCH] Proposed Fix
Comment 2 WebKit Commit Bot 2015-12-17 17:22:24 PST
Attachment 267599 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:75:  WITH_SCOPE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:76:  CLOSURE_SCOPE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:77:  CATCH_SCOPE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:78:  FUNCTION_NAME_SCOPE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:79:  GLOBAL_LEXICAL_ENVIRONMENT_SCOPE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
ERROR: Source/JavaScriptCore/inspector/JSJavaScriptCallFrame.h:80:  NESTED_LEXICAL_SCOPE is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Total errors found: 6 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 WebKit Commit Bot 2015-12-17 20:18:28 PST
Comment on attachment 267599 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 267599

Committed r194259: <http://trac.webkit.org/changeset/194259>
Comment 4 WebKit Commit Bot 2015-12-17 20:18:32 PST
All reviewed patches have been landed.  Closing bug.