Bug 152332 - REGRESSION: Selecting contents in iframe scrolls the page down
Summary: REGRESSION: Selecting contents in iframe scrolls the page down
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Frames (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh OS X 10.11
: P1 Blocker
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-16 01:35 PST by Johan "Spocke" Sörlin
Modified: 2016-02-01 00:42 PST (History)
0 users

See Also:


Attachments
Shows the bug when selecting contents. (262 bytes, text/html)
2015-12-16 01:35 PST, Johan "Spocke" Sörlin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johan "Spocke" Sörlin 2015-12-16 01:35:09 PST
Created attachment 267451 [details]
Shows the bug when selecting contents.

1. Open the attached iframe-selection-test.html
2. Scroll down to iframe.
3. Try to select contents inside the iframe.
4. Observe that the parent page is scrolled down.

This happens in Safari 9.0.2 and the latest nightly build (r194132).

This is a major regression and there is no way for us to prevent this from happening from the JS side. It affects editors like TinyMCE but also any iframe on pages with scroll.
Comment 1 Johan "Spocke" Sörlin 2016-02-01 00:42:06 PST
This is a duplicate of https://bugs.webkit.org/show_bug.cgi?id=152541 and marked as RESOLVED FIXED.