Bug 15197 - REGRESSION: Some Yahoo text entry fields render as lines rather than text entry boxes.
Summary: REGRESSION: Some Yahoo text entry fields render as lines rather than text ent...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh PowerPC OS X 10.4
: P1 Major
Assignee: Darin Adler
URL: http://help.yahoo.com/l/us/yahoo/360/...
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-09-12 15:42 PDT by CW
Modified: 2007-09-14 08:49 PDT (History)
3 users (show)

See Also:


Attachments
patch with ChangeLog and regression test case (68.03 KB, patch)
2007-09-13 17:56 PDT, Darin Adler
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description CW 2007-09-12 15:42:23 PDT
On an iMac G5 running OS X 10.4.10, in Safari Version 3.0.3 (522.12.1), under nightly WebKit, text entry fields on this page, under item numbers 3. & 6., render as flat lines.

This also occurs in other Yahoo "help" forms of this type.

It doesn't happen in Firefox.

A conflict between Yahoo!'s coding and Safari's resizable text fields?

CW
Comment 1 Mark Rowe (bdash) 2007-09-12 16:23:06 PDT
Reduction:

data:text/html,%3Ctextarea%20rows=%220%22%20cols=%220%22%3E%3C/textarea%3E

This renders as a line (zero rows tall) in WebKit, while Firefox displays it three rows tall.
Comment 2 Mark Rowe (bdash) 2007-09-12 16:24:13 PDT
<rdar://problem/5478271>
Comment 3 David Kilzer (:ddkilzer) 2007-09-12 23:06:52 PDT
This is a regression from Safari 2.0.4 (419.3) with original WebKit on Mac OS X 10.4.10 (8R218).

Safari 2.0.4 (419.3) apparently has a minimum of rows=1 and cols=1 since the test case renders the same as <textarea rows="1" cols="1"></textarea>.

Comment 4 Darin Adler 2007-09-13 17:34:14 PDT
I've got this fixed.
Comment 5 Darin Adler 2007-09-13 17:56:25 PDT
Created attachment 16285 [details]
patch with ChangeLog and regression test case
Comment 6 mitz 2007-09-14 01:19:04 PDT
Comment on attachment 16285 [details]
patch with ChangeLog and regression test case

r=me
Comment 7 Darin Adler 2007-09-14 08:49:36 PDT
r25562