Bug 15184 - EA Website broken in Safari and WebKit r25484; fine in Firefox
Summary: EA Website broken in Safari and WebKit r25484; fine in Firefox
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.commandandconquer.com/inte...
Keywords: InRadar, NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-09-11 15:07 PDT by Alexei Svitkine
Modified: 2013-07-29 11:28 PDT (History)
3 users (show)

See Also:


Attachments
Reduction (1.24 KB, text/html)
2008-02-21 20:59 PST, Sam Stigler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexei Svitkine 2007-09-11 15:07:12 PDT
The website at:

http://www.commandandconquer.com/intel/default.aspx?id=61#NewsMain

Does not display correctly in either Safari 2.0 or WebKit r25484. However, it renders fine under Firefox.
Comment 1 David Kilzer (:ddkilzer) 2007-09-11 20:58:12 PDT
Confirmed with a local debug build of WebKit r25488 with Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

Spoofing as Firefox 2.0.0.2 and MSIE 6.0 does not change the rendering behavior.

Comment 2 David Kilzer (:ddkilzer) 2007-09-11 21:00:11 PDT
<rdar://problem/5476102>
Comment 3 Sam Stigler 2008-02-21 20:59:33 PST
Created attachment 19271 [details]
Reduction

I've managed to reduce this down to what looks like a CSS issue, although it could have something to do with JavaScript.  A div that is supposed to float left is being rendered on the right side of the page; however, what makes it complicated is the div is being fed by what appears to be an XML feed.
Comment 4 Sam Stigler 2008-02-21 21:01:41 PST
Forgot to mention, I created the reduction using r30459 on 10.5.2.
Comment 5 Evan 2008-06-13 15:05:20 PDT
any update on the status of this???
Comment 6 Deirdre Saoirse Moen 2008-06-13 17:38:15 PDT
Seems more likely a dom issue given the 141 validation errors.
Comment 7 Evan 2008-11-13 15:35:50 PST
Since the site was redesigned sometime in the last couple of months...

In the latest nightly (r38297) the site seems to be rendered perfectly.
Comment 8 Robert Hogan 2013-07-29 11:27:30 PDT
The reduction looks OK to me on WebKit ToT. Is there still a bug here?
Comment 9 Robert Hogan 2013-07-29 11:28:01 PDT
I'm pretty confident there's no bug here anymore, so closing. Re-open if I'm wrong please.