Bug 151448 - storage/indexeddb/modern/cursor tests flakily time out on mac-wk1
Summary: storage/indexeddb/modern/cursor tests flakily time out on mac-wk1
Status: RESOLVED DUPLICATE of bug 151507
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Macintosh Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 149117
  Show dependency treegraph
 
Reported: 2015-11-19 10:57 PST by Ryan Haddad
Modified: 2015-12-08 15:58 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ryan Haddad 2015-11-19 13:03:16 PST
Same for storage/indexeddb/modern/cursor-3.html

Flakiness dashboard:
<http://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=storage%2Findexeddb%2Fmodern%2Fcursor-3.html>
Comment 2 Ryan Haddad 2015-11-19 13:05:22 PST
(In reply to comment #1)
> Same for storage/indexeddb/modern/cursor-3.html
> 
> Flakiness dashboard:
> <http://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.
> html#showAllRuns=true&tests=storage%2Findexeddb%2Fmodern%2Fcursor-3.html>

Marked as flaky in <https://trac.webkit.org/r192655>
Comment 3 Brady Eidson 2015-11-20 10:38:46 PST
These timeout is because an IDBTransaction callback was never received in javascript on the test web page.

This could be because the IDBTransaction's wrapper was garbage collected, so the callback could not be made.

I noticed this happening while working on https://bugs.webkit.org/show_bug.cgi?id=151456, and it will be fixed when that patch lands.

This might go away after that.
Comment 4 Brady Eidson 2015-11-20 12:24:36 PST

*** This bug has been marked as a duplicate of bug 151507 ***
Comment 5 Brady Eidson 2015-12-08 15:58:54 PST
Flakiness dashboard says these pass now.