Bug 150854 - Remove LegacyIDB
Summary: Remove LegacyIDB
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: Safari 9
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords:
: 153848 153849 (view as bug list)
Depends on:
Blocks: 149117 151890 154273
  Show dependency treegraph
 
Reported: 2015-11-03 13:32 PST by Brady Eidson
Modified: 2016-02-25 15:01 PST (History)
4 users (show)

See Also:


Attachments
Patch v1 (756.28 KB, patch)
2016-02-25 12:03 PST, Brady Eidson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2015-11-03 13:32:35 PST
Remove LegacyIDB

This includes:
-Removing the legacy/* directory
-Removing the layer of inheritance between the abstract "IDBFoo" and "IDBFooImpl" objects
-Doing a sweep of Deprecated::ScriptValue to JSValue replacement in those IDBFoo interfaces
-Probably other stuff
Comment 1 Brady Eidson 2015-11-26 21:32:11 PST
(In reply to comment #0)
> Remove LegacyIDB
> 
> This includes:
> -Removing the legacy/* directory
> -Removing the layer of inheritance between the abstract "IDBFoo" and
> "IDBFooImpl" objects
> -Doing a sweep of Deprecated::ScriptValue to JSValue replacement in those
> IDBFoo interfaces
> -Probably other stuff

-Remove unnecessary cruft from IDBGetResult (marked by a fixme with this bug #)
Comment 2 Brady Eidson 2016-02-04 11:36:32 PST
*** Bug 153848 has been marked as a duplicate of this bug. ***
Comment 3 Brady Eidson 2016-02-04 11:36:38 PST
*** Bug 153849 has been marked as a duplicate of this bug. ***
Comment 4 Brady Eidson 2016-02-04 11:37:12 PST
(In reply to comment #1)
> (In reply to comment #0)
> > Remove LegacyIDB
> > 
> > This includes:
> > -Removing the legacy/* directory
> > -Removing the layer of inheritance between the abstract "IDBFoo" and
> > "IDBFooImpl" objects
> > -Doing a sweep of Deprecated::ScriptValue to JSValue replacement in those
> > IDBFoo interfaces
> > -Probably other stuff
> 
> -Remove unnecessary cruft from IDBGetResult (marked by a fixme with this bug
> #)

Removing the current WK2 specific TestExpectations for IndexedDB tests
Comment 5 Brady Eidson 2016-02-25 11:39:52 PST
After http://trac.webkit.org/changeset/197122, Legacy IDB is no longer needed.

I'm writing the patch today.
Comment 6 Brady Eidson 2016-02-25 12:03:27 PST
Created attachment 272223 [details]
Patch v1

Ready for review now.

No cq? because I want all EWS to run first
Comment 7 Brady Eidson 2016-02-25 12:22:30 PST
(In reply to comment #4)
> (In reply to comment #1)
> > (In reply to comment #0)
> > > Remove LegacyIDB
> > > 
> > > This includes:
> > > -Removing the legacy/* directory
> > > -Removing the layer of inheritance between the abstract "IDBFoo" and
> > > "IDBFooImpl" objects
> > > -Doing a sweep of Deprecated::ScriptValue to JSValue replacement in those
> > > IDBFoo interfaces
> > > -Probably other stuff
> > 
> > -Remove unnecessary cruft from IDBGetResult (marked by a fixme with this bug
> > #)
> 
> Removing the current WK2 specific TestExpectations for IndexedDB tests


Most of these things weren't directly addressed in the huge patch up for review right now.

That's okay.

They'll come later.
Comment 8 WebKit Commit Bot 2016-02-25 14:19:04 PST
Comment on attachment 272223 [details]
Patch v1

Clearing flags on attachment: 272223

Committed r197131: <http://trac.webkit.org/changeset/197131>
Comment 9 WebKit Commit Bot 2016-02-25 14:19:07 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Michael Catanzaro 2016-02-25 15:01:26 PST
Congratulations Brady!