Bug 150228 - [EFL] Bump EFL version to 1.16.0
Summary: [EFL] Bump EFL version to 1.16.0
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Csaba Osztrogonác
URL:
Keywords:
Depends on: 151188
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 02:23 PDT by Csaba Osztrogonác
Modified: 2015-11-12 05:16 PST (History)
4 users (show)

See Also:


Attachments
Patch (2.00 KB, patch)
2015-10-16 02:26 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (4.23 KB, patch)
2015-11-09 03:48 PST, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2015-10-16 02:23:26 PDT
EFL 1.16.0 will be released on 2015.11.02. 
Once it is released, we should bump.
Comment 1 Csaba Osztrogonác 2015-10-16 02:26:23 PDT
Created attachment 263252 [details]
Patch

Now beta1 is out, it builds fine for me, no change on test results.
Comment 2 Csaba Osztrogonác 2015-11-09 03:48:44 PST
Created attachment 265039 [details]
Patch

build works fine, I'm going to run tests soon.
Comment 3 Csaba Osztrogonác 2015-11-09 04:56:59 PST
(In reply to comment #2)
> Created attachment 265039 [details]
> Patch

All tests crash for me with the xvfb driver with Intel GPU:
...
ERR<26401>:ecore_evas modules/ecore_evas/engines/x/ecore_evas_x.c:4514 ecore_evas_gl_x11_options_new_internal() evas_engine_info_set() init engine 'opengl_x11' failed.
ERR<26401>:evas_main lib/evas/canvas/evas_gl.c:151 evas_gl_new() Evas GL engine not available.
...

Unfortunately I still can't run tests with NVidia GPU with xvfb. :-/
( https://bugs.webkit.org/show_bug.cgi?id=146104 )

But the official EFL buildbot still runs tests inside xvfb
( since http://trac.webkit.org/changeset/185583 )

Gyuyoung, could you check if there is any regression with the newer EFL ?
Comment 4 Gyuyoung Kim 2015-11-09 05:57:26 PST
(In reply to comment #3)
> (In reply to comment #2)
> > Created attachment 265039 [details]
> > Patch
> 
> All tests crash for me with the xvfb driver with Intel GPU:
> ...
> ERR<26401>:ecore_evas modules/ecore_evas/engines/x/ecore_evas_x.c:4514
> ecore_evas_gl_x11_options_new_internal() evas_engine_info_set() init engine
> 'opengl_x11' failed.
> ERR<26401>:evas_main lib/evas/canvas/evas_gl.c:151 evas_gl_new() Evas GL
> engine not available.
> ...
> 
> Unfortunately I still can't run tests with NVidia GPU with xvfb. :-/
> ( https://bugs.webkit.org/show_bug.cgi?id=146104 )
> 
> But the official EFL buildbot still runs tests inside xvfb
> ( since http://trac.webkit.org/changeset/185583 )
> 
> Gyuyoung, could you check if there is any regression with the newer EFL ?

Ok, let me check it soon.
Comment 5 Gyuyoung Kim 2015-11-09 07:03:37 PST
When I run WebKit-EFL with this patch, there looks no regression. Layout Test, MiniBrowser are fine.
Comment 6 Csaba Osztrogonác 2015-11-09 07:27:10 PST
(In reply to comment #3)
> Unfortunately I still can't run tests with NVidia GPU with xvfb. :-/
> ( https://bugs.webkit.org/show_bug.cgi?id=146104 )

Fortunately is not true anymore, I managed to run 
tests and got similar results to the EFL buildbot.
Comment 7 WebKit Commit Bot 2015-11-12 02:50:02 PST
Comment on attachment 265039 [details]
Patch

Clearing flags on attachment: 265039

Committed r192358: <http://trac.webkit.org/changeset/192358>
Comment 8 WebKit Commit Bot 2015-11-12 02:50:07 PST
All reviewed patches have been landed.  Closing bug.