Bug 149815 - Fix run-javascriptcore-tests/run-jsc-stress-tests to work with rootless, add a --quick option and deprecate the Mozilla driver.
Summary: Fix run-javascriptcore-tests/run-jsc-stress-tests to work with rootless, add ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Keith Miller
URL:
Keywords: InRadar
: 149675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-05 11:54 PDT by Keith Miller
Modified: 2016-03-10 08:26 PST (History)
6 users (show)

See Also:


Attachments
Patch (20.42 KB, patch)
2015-10-05 16:21 PDT, Keith Miller
no flags Details | Formatted Diff | Diff
Patch (20.76 KB, patch)
2015-10-06 10:50 PDT, Keith Miller
fpizlo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Miller 2015-10-05 11:54:53 PDT
Fix run-javascriptcore-tests/run-jsc-stress-tests to work with rootless, add a --quick option and deprecate the Mozilla driver.
Comment 1 Keith Miller 2015-10-05 16:21:55 PDT
Created attachment 262478 [details]
Patch
Comment 2 Alexey Proskuryakov 2015-10-05 19:03:55 PDT
Comment on attachment 262478 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=262478&action=review

> Tools/ChangeLog:11
> +        Finally, I removed the calls to the mozilla jsDriver.pl it appears unused.

I do not think that it is unused. In fact, this code path is where we see the crash on llint cloop bot.
Comment 3 Keith Miller 2015-10-06 09:43:27 PDT
Comment on attachment 262478 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=262478&action=review

>> Tools/ChangeLog:11
>> +        Finally, I removed the calls to the mozilla jsDriver.pl it appears unused.
> 
> I do not think that it is unused. In fact, this code path is where we see the crash on llint cloop bot.

I guess I phrased that poorly. I had a discussion offline with Filip and Geoff and the consensus was that we should only use one test driver. Currently, `run-javascript-core tests --jsc-stress` will run all the mozilla tests so keeping the mozilla driver is just more maintenance. I'll clarify the ChangeLog.
Comment 4 Keith Miller 2015-10-06 10:50:53 PDT
Created attachment 262525 [details]
Patch
Comment 5 Keith Miller 2015-10-06 11:40:03 PDT
*** Bug 149675 has been marked as a duplicate of this bug. ***
Comment 6 Keith Miller 2015-10-06 11:41:52 PDT
rdar://problem/22918927
Comment 7 Radar WebKit Bug Importer 2015-10-06 11:42:31 PDT
<rdar://problem/22994825>
Comment 8 Keith Miller 2015-10-06 11:45:32 PDT
Committed r190630: <http://trac.webkit.org/changeset/190630>