Bug 14920 - REGRESSION: Yahoo.com main page rollovers render incorrectly
Summary: REGRESSION: Yahoo.com main page rollovers render incorrectly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL: http://www.yahoo.com/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-08-09 12:40 PDT by Samuel Allen
Modified: 2007-09-01 02:43 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Allen 2007-08-09 12:40:40 PDT
I would be surprised if this was not known about, but the front page of Yahoo.com shows obvious rendering errors on Windows Vista Safari ToT (although not the released Safari 3.0.3). In the upper right of the page, there is a special area where the boxes will expand when the mouse pointer is hovered on top of them. In ToT on Windows, the boxes do not restyle correctly when hovered. Additionally, the tabs on the two main sections of the page ("Featured", "Entertainment", "Sports", "Life") do not change appearance correctly when they are clicked on, although the content changes appropriately. 

I can attach screenshots, but the problem seems obvious enough to me that they should not be necessary.
Comment 1 Geoffrey Garen 2007-08-09 13:56:06 PDT
Works for me with TOT on Mac. Maybe Windows-specific?
Comment 2 Geoffrey Garen 2007-08-09 13:56:54 PDT
<rdar://problem/5399246>
Comment 3 Samuel Allen 2007-08-31 22:58:45 PDT
This was fixed by a recent checkin for VC compatibility.
Comment 4 David Kilzer (:ddkilzer) 2007-09-01 02:43:55 PDT
http://trac.webkit.org/projects/webkit/changeset/25329