Bug 14852 - REGRESSION: Gmail links do not load
Summary: REGRESSION: Gmail links do not load
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://gmail.com/
Keywords: GoogleBug, Regression
Depends on:
Blocks:
 
Reported: 2007-08-01 10:44 PDT by Matt Lilek
Modified: 2007-11-19 17:49 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2007-08-01 10:44:07 PDT
In Gmail, clicking a link opens a new window but does not load the page.  The progress bar can be seen turning blue briefly but doesn't do anything, nor is any URL in the address bar.  Right clicking the link also does not display any context menu, but simply pops open the new window.

This is a regression from Safari 2 and occurs in Safari 3.0.3 Beta and ToT (r24803).
Comment 1 David Kilzer (:ddkilzer) 2007-08-02 06:15:03 PDT
This works for me with a local debug build of WebKit r24803 and Safari 3 Public Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).

Comment 2 Matt Lilek 2007-08-02 10:29:11 PDT
(In reply to comment #1)
> This works for me with a local debug build of WebKit r24803 and Safari 3 Public
> Beta v. 3.0.3 (522.12.1) on Mac OS X 10.4.10 (8R218).
> 

I can still reproduce using the same build/versions as you, although the lack of a context menu might have been just a fluke as I cannot reproduce that aspect of it.  Right clicking and choosing open in a new window/tab both work, but clicking  any external link within Gmail still does not load.

That said, I'm going to lower this to P2 until someone else can confirm the same behavior I'm seeing or I figure out what's up with my setup that's causing this.  I'm sure there'd be a ton of bug reports on this if it were a widespread issue.
Comment 3 Matt Lilek 2007-11-19 17:49:43 PST
I could never reproduce this on another machine and mine's fine after a reinstall.