Bug 14843 - Crash while rendering SVG
Summary: Crash while rendering SVG
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://devel0.gcrc.carleton.ca/saf303...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-08-01 07:27 PDT by Jean-Pierre Fiset
Modified: 2007-08-02 09:55 PDT (History)
3 users (show)

See Also:


Attachments
Elaborate test case (169.42 KB, application/octet-stream)
2007-08-01 07:28 PDT, Jean-Pierre Fiset
no flags Details
Crash log (20.19 KB, text/plain)
2007-08-01 07:38 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Pierre Fiset 2007-08-01 07:27:09 PDT
I have a test case that reproduces a crash in Safari 3.0.3 on MacOS and Windows. The test case is complex and I am hoping a debugger can pin point the issue since I am at a loss at providing a simpler test case.
Comment 1 Jean-Pierre Fiset 2007-08-01 07:28:45 PDT
Created attachment 15773 [details]
Elaborate test case

This is the test case referred to by the URL, offered here in case one can not reach the given URL.
Comment 2 David Kilzer (:ddkilzer) 2007-08-01 07:38:23 PDT
* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Open the URL in this page (or index.html in the attached test case).
3. Click on the green triangle.

* RESULTS
Safari crashes after clicking on the green triangle.

* REGRESSION
Confirmed crash with Safari 3 Public Beta v. 3.0.3 (522.12.1) with its original WebKit on Mac OS X 10.4.10 (8R218).

However, Safari 3 Public Beta v. 3.0.3 (522.12.1) with a local debug build of WebKit r24803 does NOT crash on 10.4.10, so this has likely been fixed already.

Comment 3 David Kilzer (:ddkilzer) 2007-08-01 07:38:55 PDT
Created attachment 15774 [details]
Crash log
Comment 4 Amos Hayes 2007-08-02 07:19:41 PDT
Safari 3 Public Beta v. 3.0.3 (522.12.1) with the webkit.org r24803 (Aug. 1) nightly on 10.4.10 does not crash for me either. So that rules out the local debug build difference, correct?
Comment 5 David Kilzer (:ddkilzer) 2007-08-02 09:55:52 PDT
(In reply to comment #4)
> Safari 3 Public Beta v. 3.0.3 (522.12.1) with the webkit.org r24803 (Aug. 1)
> nightly on 10.4.10 does not crash for me either. So that rules out the local
> debug build difference, correct?

Yes.  It's rare that a debug build works and a release build doesn't, but it happens.

I think this bug may be closed since it's fixed in tip-of-tree.