Bug 148055 - [ES6] Arrow function syntax. Arrow function specific features. Lexical bind "new.target"
Summary: [ES6] Arrow function syntax. Arrow function specific features. Lexical bind "...
Status: RESOLVED DUPLICATE of bug 149338
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 149338 154514
Blocks: 140855
  Show dependency treegraph
 
Reported: 2015-08-15 07:17 PDT by GSkachkov
Modified: 2016-02-21 11:33 PST (History)
1 user (show)

See Also:


Attachments
Patch (28.17 KB, patch)
2015-08-15 07:24 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (28.35 KB, patch)
2015-08-15 07:53 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (28.25 KB, patch)
2015-08-15 08:19 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (28.30 KB, patch)
2015-08-15 10:48 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (28.30 KB, patch)
2015-08-15 13:26 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (173.30 KB, patch)
2015-08-16 04:25 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (173.42 KB, patch)
2015-08-16 06:45 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (173.58 KB, patch)
2015-08-16 07:14 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (173.86 KB, patch)
2015-08-16 11:45 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.08 KB, patch)
2015-08-16 12:30 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.27 KB, patch)
2015-08-16 23:47 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.30 KB, patch)
2015-08-17 00:13 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.84 KB, patch)
2015-08-17 00:44 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.65 KB, patch)
2015-08-17 01:16 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.94 KB, patch)
2015-08-17 06:13 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.82 KB, patch)
2015-08-17 06:52 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (175.89 KB, patch)
2015-08-17 07:23 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (175.80 KB, patch)
2015-08-17 07:51 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.65 KB, patch)
2015-08-17 08:14 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.39 KB, patch)
2015-08-17 08:30 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (174.75 KB, patch)
2015-08-17 08:42 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (175.28 KB, patch)
2015-08-17 09:03 PDT, GSkachkov
no flags Details | Formatted Diff | Diff
Patch (172.48 KB, patch)
2015-08-17 11:01 PDT, GSkachkov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description GSkachkov 2015-08-15 07:17:51 PDT
Implement lexical bind of 'super' & 'new.target' in call arrow function inside of the class
Comment 1 GSkachkov 2015-08-15 07:24:58 PDT
Created attachment 259091 [details]
Patch

Fix win build
Comment 2 GSkachkov 2015-08-15 07:53:18 PDT
Created attachment 259092 [details]
Patch

Fix win build
Comment 3 GSkachkov 2015-08-15 08:19:29 PDT
Created attachment 259093 [details]
Patch

Fix win build
Comment 4 GSkachkov 2015-08-15 10:48:31 PDT
Created attachment 259096 [details]
Patch

Fix win build
Comment 5 WebKit Commit Bot 2015-08-15 11:06:34 PDT
Attachment 259096 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/JSArrowFunction.cpp:50:  When wrapping a line, only indent 4 spaces.  [whitespace/indent] [3]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 GSkachkov 2015-08-15 13:26:16 PDT
Created attachment 259103 [details]
Patch

Fix win build
Comment 7 WebKit Commit Bot 2015-08-15 13:30:13 PDT
Attachment 259103 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/runtime/JSArrowFunction.cpp:50:  When wrapping a line, only indent 4 spaces.  [whitespace/indent] [3]
Total errors found: 1 in 11 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 8 GSkachkov 2015-08-16 04:25:47 PDT
Created attachment 259122 [details]
Patch

Fix win build
Comment 9 GSkachkov 2015-08-16 06:45:24 PDT
Created attachment 259123 [details]
Patch

Fix win build
Comment 10 GSkachkov 2015-08-16 07:14:18 PDT
Created attachment 259124 [details]
Patch

Fix win build
Comment 11 GSkachkov 2015-08-16 11:45:12 PDT
Created attachment 259127 [details]
Patch

Fix win build
Comment 12 GSkachkov 2015-08-16 12:30:44 PDT
Created attachment 259128 [details]
Patch

Fix win build
Comment 13 GSkachkov 2015-08-16 23:47:22 PDT
Created attachment 259135 [details]
Patch

Fix win build
Comment 14 GSkachkov 2015-08-17 00:13:05 PDT
Created attachment 259136 [details]
Patch

Fix win build
Comment 15 GSkachkov 2015-08-17 00:44:36 PDT
Created attachment 259137 [details]
Patch

Fix win build
Comment 16 GSkachkov 2015-08-17 01:16:07 PDT
Created attachment 259139 [details]
Patch

Fix win build
Comment 17 GSkachkov 2015-08-17 06:13:32 PDT
Created attachment 259143 [details]
Patch

Fix win build
Comment 18 GSkachkov 2015-08-17 06:52:49 PDT
Created attachment 259144 [details]
Patch

Fix win build
Comment 19 GSkachkov 2015-08-17 07:23:24 PDT
Created attachment 259146 [details]
Patch

Fix win build
Comment 20 GSkachkov 2015-08-17 07:51:20 PDT
Created attachment 259148 [details]
Patch

Fix win build
Comment 21 GSkachkov 2015-08-17 08:14:59 PDT
Created attachment 259149 [details]
Patch

Fix win build
Comment 22 GSkachkov 2015-08-17 08:30:12 PDT
Created attachment 259150 [details]
Patch

Fix win build
Comment 23 GSkachkov 2015-08-17 08:42:41 PDT
Created attachment 259151 [details]
Patch

Fix win build
Comment 24 GSkachkov 2015-08-17 09:03:48 PDT
Created attachment 259152 [details]
Patch

Fix win build
Comment 25 GSkachkov 2015-08-17 11:01:12 PDT
Created attachment 259162 [details]
Patch

Fix win build
Comment 26 GSkachkov 2015-12-10 06:42:46 PST
Issue is implemented in 149338, so can be closed https://bugs.webkit.org/show_bug.cgi?id=149338
Comment 27 GSkachkov 2015-12-10 06:43:18 PST

*** This bug has been marked as a duplicate of bug 149338 ***