Bug 147948 - Web Inspector: CRASH under WebInspector::closeFrontend for some protocol tests
Summary: Web Inspector: CRASH under WebInspector::closeFrontend for some protocol tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: BJ Burg
URL:
Keywords: DoNotImportToRadar
Depends on:
Blocks: 147954
  Show dependency treegraph
 
Reported: 2015-08-12 13:04 PDT by BJ Burg
Modified: 2015-08-12 16:03 PDT (History)
8 users (show)

See Also:


Attachments
Proposed Fix (2.61 KB, patch)
2015-08-12 14:17 PDT, BJ Burg
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description BJ Burg 2015-08-12 13:04:34 PDT
I think this is happening during teardown in some protocol tests, though I can't exactly pinpoint the conditions for reproducing the crash. It has not been appearing on the bots, but I have run into it hard in my current work on <https://webkit.org/b/147934>

NOTES:

The WKTR harness automatically calls WKInspectorClose at the end of a test run, but the real inspector may not have been opened at that point. Regardless, it sends a WebInspector::Close message on the frontend connection, which may have not been initialized. I think this can be solved with an early exit in WebInspector::closeFrontend().
Comment 1 BJ Burg 2015-08-12 13:04:58 PDT
<rdar://problem/18545278>
Comment 2 BJ Burg 2015-08-12 14:17:02 PDT
Created attachment 258846 [details]
Proposed Fix
Comment 3 BJ Burg 2015-08-12 14:31:09 PDT
Adding this as a blocking bug, since it seems to be triggered by the refactoring.
Comment 4 Joseph Pecoraro 2015-08-12 15:12:14 PDT
Comment on attachment 258846 [details]
Proposed Fix

r=me
Comment 5 WebKit Commit Bot 2015-08-12 16:03:02 PDT
Comment on attachment 258846 [details]
Proposed Fix

Clearing flags on attachment: 258846

Committed r188362: <http://trac.webkit.org/changeset/188362>
Comment 6 WebKit Commit Bot 2015-08-12 16:03:05 PDT
All reviewed patches have been landed.  Closing bug.