Bug 147818 - Regression(r188105): Seems to have caused crashes during PLT on some iPads
Summary: Regression(r188105): Seems to have caused crashes during PLT on some iPads
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Yusuke Suzuki
URL:
Keywords: InRadar
Depends on:
Blocks: 147480
  Show dependency treegraph
 
Reported: 2015-08-09 14:59 PDT by Chris Dumez
Modified: 2015-08-09 20:24 PDT (History)
4 users (show)

See Also:


Attachments
Roll out (143.48 KB, patch)
2015-08-09 15:02 PDT, Chris Dumez
cdumez: commit-queue-
Details | Formatted Diff | Diff
Roll out (129.29 KB, patch)
2015-08-09 15:06 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (144.95 KB, patch)
2015-08-09 15:49 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (144.92 KB, patch)
2015-08-09 15:55 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2015-08-09 14:59:47 PDT
r188105 seems to have caused crashes during PLT on some iPads
Comment 1 Chris Dumez 2015-08-09 15:00:24 PDT
rdar://problem/22205881
Comment 2 Chris Dumez 2015-08-09 15:02:26 PDT
Created attachment 258597 [details]
Roll out
Comment 3 Chris Dumez 2015-08-09 15:04:03 PDT
Comment on attachment 258597 [details]
Roll out

Need to tweak the change logs.
Comment 4 Chris Dumez 2015-08-09 15:06:55 PDT
Created attachment 258598 [details]
Roll out
Comment 5 Yusuke Suzuki 2015-08-09 15:17:13 PDT
Comment on attachment 258598 [details]
Roll out

r=me
Comment 6 Chris Dumez 2015-08-09 15:49:30 PDT
Created attachment 258599 [details]
Patch
Comment 7 WebKit Commit Bot 2015-08-09 15:53:47 PDT
Comment on attachment 258599 [details]
Patch

Rejecting attachment 258599 [details] from commit-queue.

Failed to run "['/Volumes/Data/EWS/WebKit/Tools/Scripts/webkit-patch', '--status-host=webkit-queues.webkit.org', '--bot-id=webkit-cq-03', 'validate-changelog', '--check-oops', '--non-interactive', 258599, '--port=mac']" exit_code: 1 cwd: /Volumes/Data/EWS/WebKit

ChangeLog entry in Source/JavaScriptCore/ChangeLog contains OOPS!.

Full output: http://webkit-queues.webkit.org/results/35839
Comment 8 Chris Dumez 2015-08-09 15:55:39 PDT
Created attachment 258600 [details]
Patch
Comment 9 Chris Dumez 2015-08-09 15:56:11 PDT
Committed r188201: <http://trac.webkit.org/changeset/188201>
Comment 10 Chris Dumez 2015-08-09 20:24:16 PDT
Looks like the roll out did fix crashes on the 32bit iPads cold PLT bots.