Bug 147726 - Media Session: rename isFocusedContentMediaElementPaused and get rid of callback
Summary: Media Session: rename isFocusedContentMediaElementPaused and get rid of callback
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 145411
  Show dependency treegraph
 
Reported: 2015-08-06 00:26 PDT by Matt Rajca
Modified: 2015-08-06 11:23 PDT (History)
6 users (show)

See Also:


Attachments
Patch (5.37 KB, patch)
2015-08-06 00:30 PDT, Matt Rajca
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Rajca 2015-08-06 00:26:10 PDT
- isFocusedContentMediaElementPaused should be renamed to isFocusedContentMediaElementPlaying to match recent refactoring work (Bug 147633).
- isFocusedContentMediaElementPlaying itself does not need a callback anymore because the value can be returned directly
Comment 1 Matt Rajca 2015-08-06 00:30:15 PDT
Created attachment 258357 [details]
Patch
Comment 2 Matt Rajca 2015-08-06 11:23:03 PDT
Committed r188048: <http://trac.webkit.org/changeset/188048>