Bug 14680 - Articles at Apple Support (docs.info.apple.com) have partially drawn borders
Summary: Articles at Apple Support (docs.info.apple.com) have partially drawn borders
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://docs.info.apple.com/article.ht...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-07-19 16:54 PDT by Charles Gaudette
Modified: 2010-12-08 14:22 PST (History)
2 users (show)

See Also:


Attachments
Screenshot (6.62 KB, image/png)
2007-07-19 16:57 PDT, Charles Gaudette
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Gaudette 2007-07-19 16:54:56 PDT
If this isn't a bug, but rather an implementation error by the web-masters I'm still login it on bugzilla for search purposes. All similarly designed article pages at Apple Support have partially drawn boarders to the right of the successfully drawn column blocks. It looks like the wrong style element where a drop shadow should be.

A quick look at the HTML/CSS shows that the page uses "-webkit" style tricks; therefore the issue described here is only seen on Safari/WebKit. Loading the page with FF2 confirms this aspect.

Pages at docs.info.apple.com are effected. Pages hanging off http://www.apple.com/support/ are not effected, for instance http://www.apple.com/support/tiger/accounts/ .

Browser details: PPC, Mac OS X 10.4.10, Safari 3.0.2 beta, WebKit r24452
Comment 1 Charles Gaudette 2007-07-19 16:57:52 PDT
Created attachment 15589 [details]
Screenshot
Comment 2 David Kilzer (:ddkilzer) 2007-07-19 18:17:43 PDT
Confirmed with a local debug build of WebKit r24443 with Safari 3.0 (522.12) on Mac OS X 10.4.10 (8R218).

Comment 3 Charles Gaudette 2007-07-27 16:19:07 PDT
I have semi-reduced this, but I'm holding at about 60 lines of HTML/CSS. I am now seeing this not as "-webkit" tricks, but as a few pixel-widths difference in how WebKit and others (like FF2) handle widths in the face of the HTML document declaring itself ``DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd"´´. 

The above width difference combined with CSS — "background: url(...kbboxtop.gif) top left repeat-x;" — is creating the effects seen in the screenshot.

The width difference might still be of interest, I'm going to continue to play with this for a few more days. The CSS repeat-x seems unnecessary, but is completely at the hands of Apple webmasters.
Comment 4 David Kilzer (:ddkilzer) 2007-07-28 07:52:48 PDT
(In reply to comment #3)
> I have semi-reduced this, but I'm holding at about 60 lines of HTML/CSS.

Attaching a partial reduction is still useful!
Comment 5 Simon Fraser (smfr) 2010-12-07 14:11:21 PST
I don't see this any more on the test URL. Without a testcase, this will have to be marked as WORKSFORME.
Comment 6 Alexey Proskuryakov 2010-12-08 14:22:25 PST
Please feel free to re-open if you have a reduced test case, or another way to reproduce this.