Bug 14676 - keypress happens twice at finance.google.com pages
Summary: keypress happens twice at finance.google.com pages
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://finance.google.com/finance?cid...
Keywords: GoogleBug, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-07-19 13:38 PDT by Alice Liu
Modified: 2007-12-03 02:58 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alice Liu 2007-07-19 13:38:17 PDT
<rdar://problem/5347825>

* SUMMARY
changeset http://trac.webkit.org/projects/webkit/changeset/21448 caused a regression where pressing key on a finance.google.com site enters the text twice in the textfield.  

* STEPS TO REPRODUCE
1. navigate to http://finance.google.com/finance?cid=13756934
2. don't use the mouse or change focus with the keyboard  just press "x"

* RESULTS
"xx" in the text field

* REGRESSION
caused by 21448.  the 21447 nightly does not exhibit the bug.
Comment 1 Alexey Proskuryakov 2007-07-20 00:47:30 PDT
This problem doesn't occur when spoofing as Netscape 7.0.
Comment 2 Adele Peterson 2007-08-30 15:56:22 PDT
This has been identified as an evangelism issue, which Google is now aware of.
Comment 3 Alexey Proskuryakov 2007-08-31 10:53:15 PDT
Since this is an evangelism issue, downgrading to P2.
Comment 4 Alexey Proskuryakov 2007-12-03 02:58:37 PST
I can no longer reproduce this problem, must have been fixed by Google.