Bug 146508 - [GTK] Accelerated Compositing stops working after a web process crash
Summary: [GTK] Accelerated Compositing stops working after a web process crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2015-07-01 03:58 PDT by Carlos Garcia Campos
Modified: 2015-07-02 00:09 PDT (History)
8 users (show)

See Also:


Attachments
Patch (3.39 KB, patch)
2015-07-01 04:00 PDT, Carlos Garcia Campos
mrobinson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2015-07-01 03:58:05 PDT
The problem is that we don't send the window ID again to the new web process.
Comment 1 Carlos Garcia Campos 2015-07-01 04:00:26 PDT
Created attachment 255915 [details]
Patch
Comment 2 WebKit Commit Bot 2015-07-01 04:01:38 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Carlos Garcia Campos 2015-07-02 00:09:26 PDT
Committed r186221: <http://trac.webkit.org/changeset/186221>