Bug 145974 - AX: feature request - make HTML5 <mark> element accessible
Summary: AX: feature request - make HTML5 <mark> element accessible
Status: RESOLVED DUPLICATE of bug 109018
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-06-15 07:11 PDT by Steve Faulkner
Modified: 2015-07-07 00:35 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Faulkner 2015-06-15 07:11:13 PDT
What steps will reproduce the problem?
1.http://thepaciellogroup.github.io/AT-browser-tests/test-files/mark.html
2. check info exposed for mark element in accessibility API


What is the expected output? 
refer to http://w3c.github.io/aria/html-aam/html-aam.html#el-mark

Note: the mapping is a guess, feedback welcome!

also see related chrome https://code.google.com/p/chromium/issues/detail?id=494612 and firefox bugs https://bugzilla.mozilla.org/show_bug.cgi?id=982125
Comment 1 Radar WebKit Bug Importer 2015-06-15 07:12:49 PDT
<rdar://problem/21381897>
Comment 2 James Craig 2015-07-07 00:35:20 PDT
Please check for dupes before filing. The accessibility bug list is not very long.

*** This bug has been marked as a duplicate of bug 109018 ***