Bug 14539 - Safari randomly can't load pages anymore
Summary: Safari randomly can't load pages anymore
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-07-06 02:45 PDT by y.kalter
Modified: 2007-08-10 06:06 PDT (History)
2 users (show)

See Also:


Attachments
Safari sample (10.21 KB, text/plain)
2007-07-11 02:26 PDT, y.kalter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description y.kalter 2007-07-06 02:45:55 PDT
Sometimes when I load a webpage, it loads up to ~50% ~75% and than stops. The site won't complete to load at that point. The problem is, when this occurs Safari refuses to load any webpage. If I go to another website it will display the blue loading bar up tp ~10% and than sits there idle. The spinning wheel keeps spinning. There are two workarounds for this. 1: shut down Safari and restart it and it will immediately load pages again. Or 2: wait for about 30 seconds and it will load webpages again. Pressing the reload button wil NOT work. If i look at the Activity Window, it says "canceled" at some .gif files. 

I can't seem to reproduce it when I want, it happens randomly. But it happens a lot at the website http://www.tweakers.net (not always). For comparison, I don't have this problem with Firefox and Camino, also my downloads (Transmission torrents) continue to download. The console application shows nothing in the logs for the time this problem occurs.

I've tried several browsers, Safari 2.0.4, 3.0.2 and the latest WebKit (522+ ?) give me this problem. And not only do I have this problem on my MacBook, I also have it on my Intel iMac. Both are connected to a wireless network (also tried changing channels, force b or g mode, and disable security but that doesn't work). And last, I don't use any haxies for my browser. Also tried to reset Safari and deleting the cache files, but the problem reoccurs everytime. And if I reinstall Mac OS X, the problem reoccurs still. I'm sometimes at a point that I have to restart my browser every 30 minutes.
Comment 1 Mark Rowe (bdash) 2007-07-06 06:16:00 PDT
Do you have any Safari extensions installed?
Comment 2 y.kalter 2007-07-06 06:24:43 PDT
(In reply to comment #1)
> Do you have any Safari extensions installed?
> 
The only things I installed that may be relevant to Safari are Flip4Mac and Flash. As far as I know, nothing else is installed that affects Safari.
Comment 3 y.kalter 2007-07-06 06:32:27 PDT
(In reply to comment #2)
> (In reply to comment #1)
> > Do you have any Safari extensions installed?
> > 
> The only things I installed that may be relevant to Safari are Flip4Mac and
> Flash. As far as I know, nothing else is installed that affects Safari.
> 
Sorry I don't know how I can edit a reply, but I didn't install Flash, that was a mistake. It worked out of the box. 
Comment 4 David Kilzer (:ddkilzer) 2007-07-07 12:52:37 PDT
In the summary, you said it doesn't work "anymore".  When did it stop working?  Where there any major changes when it stopped working (like a change of ISP, or new network hardware)?

Does your MacBook have issues if you connect via a completely different network (e.g., home versus work)?

If you bypass your wireless router (e.g., use a wired connection directly), does that ever exhibit the issue?

Do you know if your ISP has an transparent HTTP proxy being used upstream from you?

Comment 5 y.kalter 2007-07-08 02:40:31 PDT
(In reply to comment #4)
> In the summary, you said it doesn't work "anymore".  When did it stop working? 
> Where there any major changes when it stopped working (like a change of ISP, or
> new network hardware)?
When I first bought my iMac, in February, i already had this wireless network. I use an updated Linksys WRT54G v2.2 router. Also, I haven't changed ISP since.

> Does your MacBook have issues if you connect via a completely different network
> (e.g., home versus work)?
At this moment I can't connect to another network. But I've tried another router yesterday (Netgear WGR614) and within minutes the problem was there again on both the MacBook and the iMac.
 
> If you bypass your wireless router (e.g., use a wired connection directly),
> does that ever exhibit the issue?
I'm going to try that today, I will report back on that later.

> Do you know if your ISP has an transparent HTTP proxy being used upstream from
> you?
Sorry, I don't know. Any way I could see that?

Also, I'm sorry if this isn't a Safari/WebKit bug, but this problem is so hard to find a solution for.
Comment 6 David Kilzer (:ddkilzer) 2007-07-08 08:59:44 PDT
(In reply to comment #5)
> (In reply to comment #4)
> > In the summary, you said it doesn't work "anymore".  When did it stop working? 
> > Where there any major changes when it stopped working (like a change of ISP, or
> > new network hardware)?
> 
> When I first bought my iMac, in February, i already had this wireless network.
> I use an updated Linksys WRT54G v2.2 router. Also, I haven't changed ISP since.

What I was trying to determine is if something changed (in the past) that caused the images to stop loading properly.  Did images always load properly before you bought your iMac?  When did they stop working?

> > If you bypass your wireless router (e.g., use a wired connection directly),
> > does that ever exhibit the issue?
> 
> I'm going to try that today, I will report back on that later.

Great!

> > Do you know if your ISP has an transparent HTTP proxy being used upstream from
> > you?
> 
> Sorry, I don't know. Any way I could see that?

Looking at the output of "curl -I URL" may give some clues.  For example, this is what I see on my network, but if you have slightly different headers, that means there could be a proxy involved:

$ curl -I http://tweakers.net/
HTTP/1.1 200 OK
Date: Sun, 08 Jul 2007 15:34:44 GMT
Server: Apache/2.2.3 (Debian)
Expires: Mon, 26 Jul 1995 05:00:00 GMT
Last-Modified: Sun, 08 Jul 2007 15:34:44 GMT
Cache-Control: no-store, no-cache, must-revalidate
Cache-Control: pre-check=0, post-check=0, max-age=0
Pragma: no-cache
P3P: CP="CUR ADM OUR NOR STA NID"
Set-Cookie: TnetID=46d844139cfb1f6671094f22eb00c113; expires=Thu, 31-Dec-2037 23:00:00 GMT; path=/; domain=.tweakers.net
Set-Cookie: tc=1183908884%2C1183908884; expires=Tue, 07-Aug-2007 15:34:44 GMT; path=/; domain=.tweakers.net
Set-Cookie: channel=main; expires=Mon, 07-Jul-2008 15:34:44 GMT; path=/; domain=.tweakers.net
Connection: close
Content-Type: text/html; charset=ISO-8859-15

> Also, I'm sorry if this isn't a Safari/WebKit bug, but this problem is so hard
> to find a solution for.

It's much easier to diagnose issues through Bugzilla, then put them in Radar (Apple's internal bug tracker) when sufficient information has been found.  Since this issue directly affects your browsing experience on Safari, it's okay to explore the issue here.

The best thing to do may be to capture a packet trace when pages aren't loading properly using the "tcpdump" command.  Here's how:

1. Open a "Terminal" window.
2. Run the "/sbin/ifconfig" command.
3. Note all of the "enX" interfaces listed.  ("en0" is usually your wired ethernet, while "en1" is usually wireless, but it's not necessarily that way.  The active interface will have a line that begins with "inet" and a valid IP address.)

4. Wait for the page loading issues to start.

5. When they do start, run this command from the Terminal (where "en1" is the interface you're using):

sudo tcpdump -s 0 -w packets.tcpdump -i en1

6. Type your account's password (assuming your account also has admin privileges).
7. Try loading a web page or two from Safari.  (Hopefully they will fail out.)
8. Hit Ctrl-C to end the command.  The tcpdump command should say that it captured more than zero packets.  If it didn't, then you either (most likely) have the wrong interface or no packets are being sent.  Try rerunning the command with the other interface and loading more web pages.

9. Attach packets.tcpdump to this bug.

NOTES: 
- DO NOT try to log into a web site while capturing packets, or your username and password will be visible in the clear.
- Do not test SSL (https) web sites when capturing packets as this will make it much more difficult to diagnose any issues.
- It would be GREAT if you could start capturing packets for a period in which web pages are loading correctly, then suddenly stop working.  This would give the most information about the issue.

Comment 7 y.kalter 2007-07-08 11:42:43 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > In the summary, you said it doesn't work "anymore".  When did it stop working? 
> > > Where there any major changes when it stopped working (like a change of ISP, or
> > > new network hardware)?
> > 
> > When I first bought my iMac, in February, i already had this wireless network.
> > I use an updated Linksys WRT54G v2.2 router. Also, I haven't changed ISP since.
> 
> What I was trying to determine is if something changed (in the past) that
> caused the images to stop loading properly.  Did images always load properly
> before you bought your iMac?  When did they stop working?

Everything worked great before I bought the Macs. My dad still has an Asus notebook running XP SP2 and it never has this problem. Also, if I use Firefox I don't have this problem on both Macs. 

> > > If you bypass your wireless router (e.g., use a wired connection directly),
> > > does that ever exhibit the issue?
> > 
> > I'm going to try that today, I will report back on that later.
> 
> Great!

I can't seem to reproduce this problem when running on a wired connection, but the problem was hard to trigger today. I will try it a bit more tommorow.

> > > Do you know if your ISP has an transparent HTTP proxy being used upstream from
> > > you?
> > 
> > Sorry, I don't know. Any way I could see that?
> 
> Looking at the output of "curl -I URL" may give some clues.  For example, this
> is what I see on my network, but if you have slightly different headers, that
> means there could be a proxy involved:
> 
<output>

Here is my output:
$ curl -I http://tweakers.net
HTTP/1.1 200 OK
Date: Sun, 08 Jul 2007 18:03:25 GMT
Server: Apache/2.2.3 (Debian)
Expires: Mon, 26 Jul 1995 05:00:00 GMT
Last-Modified: Sun, 08 Jul 2007 18:03:25 GMT
Cache-Control: no-store, no-cache, must-revalidate
Cache-Control: pre-check=0, post-check=0, max-age=0
Pragma: no-cache
P3P: CP="CUR ADM OUR NOR STA NID"
Set-Cookie: TnetID=ea9e118392151de82cc78e3f4a9ed0d7; expires=Thu, 31-Dec-2037 23:00:00 GMT; path=/; domain=.tweakers.net
Set-Cookie: tc=1183917805%2C1183917805; expires=Tue, 07-Aug-2007 18:03:25 GMT; path=/; domain=.tweakers.net
Set-Cookie: channel=main; expires=Mon, 07-Jul-2008 18:03:25 GMT; path=/; domain=.tweakers.net
Connection: close
Content-Type: text/html; charset=ISO-8859-15

> > Also, I'm sorry if this isn't a Safari/WebKit bug, but this problem is so hard
> > to find a solution for.
> 
> It's much easier to diagnose issues through Bugzilla, then put them in Radar
> (Apple's internal bug tracker) when sufficient information has been found. 
> Since this issue directly affects your browsing experience on Safari, it's okay
> to explore the issue here.
> 
> The best thing to do may be to capture a packet trace when pages aren't loading
> properly using the "tcpdump" command.  Here's how:
> 
<instructions>

I let that command run and opened up Safari. I let it load a thread (with many images) on the Tweakers.net forum (got.tweakers.net) and it locked up. I attached the packets.tcpdump file above.

Thank you for your help so far.
Comment 8 y.kalter 2007-07-08 11:48:06 PDT
Hmm, the file was to big so I uploaded it to my webserver if that's no problem.

Address: http://members.home.nl/j.kalter/files/packets.tcpdump
Comment 9 David Kilzer (:ddkilzer) 2007-07-08 14:41:14 PDT
(In reply to comment #7)
> I let that command run and opened up Safari. I let it load a thread (with many
> images) on the Tweakers.net forum (got.tweakers.net) and it locked up. I
> attached the packets.tcpdump file above.

Could you do something else for me?  When Safari "locks up" (and I assume that it starts "beach-balling"), could you run this command and attach the output to this bug?

$ sample Safari 10 10

The output from the command will look like this (please attach the file created in /tmp):

Sampling process 20504 each 10 msecs 1000 times
Sample analysis of process 20504 written to file /tmp/Safari_20504.sample.txt

Thanks!

Comment 10 y.kalter 2007-07-08 14:49:13 PDT
(In reply to comment #9)
> (In reply to comment #7)
> > I let that command run and opened up Safari. I let it load a thread (with many
> > images) on the Tweakers.net forum (got.tweakers.net) and it locked up. I
> > attached the packets.tcpdump file above.
> 
> Could you do something else for me?  When Safari "locks up" (and I assume that
> it starts "beach-balling"), could you run this command and attach the output to
> this bug?
> 
> $ sample Safari 10 10
> 
> The output from the command will look like this (please attach the file created
> in /tmp):
> 
> Sampling process 20504 each 10 msecs 1000 times
> Sample analysis of process 20504 written to file /tmp/Safari_20504.sample.txt
> 
> Thanks!
> 

Wrong choice of words from me I think. When the problem occurs, Safari is still responsive. At that moment the cursor will not change into the spinning beachball. Only the loading circle next to the title of the page in a tab spins and the loading bar is partly blue. Should I still run the command?
Comment 11 David Kilzer (:ddkilzer) 2007-07-08 14:52:43 PDT
(In reply to comment #10)
> Wrong choice of words from me I think. When the problem occurs, Safari is still
> responsive. At that moment the cursor will not change into the spinning
> beachball. Only the loading circle next to the title of the page in a tab spins
> and the loading bar is partly blue. Should I still run the command?

Even though it's not beach-balling, I'd still like you to run the command.  You might also run the tcpdump command in another window at the same time (so we're capturing data for the same event).  Thanks!
Comment 12 David Kilzer (:ddkilzer) 2007-07-08 15:02:21 PDT
(In reply to comment #7)
> Everything worked great before I bought the Macs. My dad still has an Asus
> notebook running XP SP2 and it never has this problem. Also, if I use Firefox I
> don't have this problem on both Macs. 

The fact that Firefox works on the Macs but Safari doesn't (at the same time) points to an issue with Safari, WebKit or CFNetwork.

Comment 13 David Kilzer (:ddkilzer) 2007-07-08 15:12:21 PDT
(In reply to comment #7)
> Here is my output:
> $ curl -I http://tweakers.net
> HTTP/1.1 200 OK
> Date: Sun, 08 Jul 2007 18:03:25 GMT
> Server: Apache/2.2.3 (Debian)
> Expires: Mon, 26 Jul 1995 05:00:00 GMT
> Last-Modified: Sun, 08 Jul 2007 18:03:25 GMT
> Cache-Control: no-store, no-cache, must-revalidate
> Cache-Control: pre-check=0, post-check=0, max-age=0
> Pragma: no-cache
> P3P: CP="CUR ADM OUR NOR STA NID"
> Set-Cookie: TnetID=ea9e118392151de82cc78e3f4a9ed0d7; expires=Thu, 31-Dec-2037
> 23:00:00 GMT; path=/; domain=.tweakers.net
> Set-Cookie: tc=1183917805%2C1183917805; expires=Tue, 07-Aug-2007 18:03:25 GMT;
> path=/; domain=.tweakers.net
> Set-Cookie: channel=main; expires=Mon, 07-Jul-2008 18:03:25 GMT; path=/;
> domain=.tweakers.net
> Connection: close
> Content-Type: text/html; charset=ISO-8859-15

I don't see any differences that would indicate an http proxy is present, but that doesn't mean there isn't one still in effect.  (However, I would expect such a proxy to affect both wired and wireless connections, which makes me think this isn't the issue.)

Comment 14 David Kilzer (:ddkilzer) 2007-07-08 22:41:35 PDT
(In reply to comment #12)
> The fact that Firefox works on the Macs but Safari doesn't (at the same time)
> points to an issue with Safari, WebKit or CFNetwork.

It may not be a software issue--could be a network configuration issue.  More below.

(In reply to comment #8)
> Hmm, the file was to big so I uploaded it to my webserver if that's no problem.
> Address: http://members.home.nl/j.kalter/files/packets.tcpdump

After opening this in Wireshark (http://www.wireshark.org/), I see a lot of packets labeled:

    [TCP segment of a reassembled PDU]

Doing a few Google searches, it looks like you may need to adjust the MTU (a network configuration parameter for a wired or wireless ethernet connection) on your wireless router and/or your Macs.  (Note that the "/sbin/ifconfig" command will list the MTU parameter for each interface as well.)

http://www.webservertalk.com/archive65-2005-12-1341279.html
http://ethereal.com/lists/ethereal-users/200604/msg00032.html

I don't recall how to change this parameter on OS X off the top of my head, but I'm sure a Google search will give some information.  For example:

http://docs.info.apple.com/article.html?artnum=303192

Not sure why your Macs would be affected while your PCs would not (assuming they're all using the wireless connection).  Perhaps the MTU on the wireless router needs to be adjusted (which will vary by router--most likely there is a web interface to do this, though)?

BTW, try changing the MTU before running sample(1) per Comment #9 and Comment #11.

Comment 15 y.kalter 2007-07-09 02:15:25 PDT
(In reply to comment #14)
> Not sure why your Macs would be affected while your PCs would not (assuming
> they're all using the wireless connection).  Perhaps the MTU on the wireless
> router needs to be adjusted (which will vary by router--most likely there is a
> web interface to do this, though)?
> 
> BTW, try changing the MTU before running sample(1) per Comment #9 and Comment
> #11.
> 

On a dutch website that contains a lot of information about my provider (@Home Netherlands) I could find a way to determine the optimal MTU size. I adjusted it in the router and the problem seems to be fixed, but I don't want to say this to early. If it doesn't work, I will also change the setting on my Macs. I will report back on the later because I have no clue if this will work or not.

Thanks for your help.
Comment 16 y.kalter 2007-07-11 02:21:14 PDT
I've tried lowering the MTU to 1300, I have to say, the problem occurs more less frequently but the Internet becomes extremely slow sometimes. Safari refuses to completely load webpages when I lower the MTU. Sometimes Google doesn't even want to load. So I must say, I can't really call it a solution.

I will try your other suggestion right now.
Comment 17 y.kalter 2007-07-11 02:26:01 PDT
Created attachment 15471 [details]
Safari sample
Comment 18 y.kalter 2007-07-11 03:22:51 PDT
(In reply to comment #16)
> I've tried lowering the MTU to 1300, I have to say, the problem occurs more
> less frequently but the Internet becomes extremely slow sometimes. Safari
> refuses to completely load webpages when I lower the MTU. Sometimes Google
> doesn't even want to load. So I must say, I can't really call it a solution.
> 
> I will try your other suggestion right now.
> 
I've tried setting the MTU to 1200 in the router, and the Internet is much more responsive at that rate for some reason. Anyway, I think the problems are gone now, on 1300 I had it less frequent than on the standard 1500 setting.
Comment 19 y.kalter 2007-07-11 03:54:53 PDT
Coming back on my reply earlier, I just experienced the problem again on my MacBook. It happened at a news item again on Tweakers.net. I don't think changing the MTU is the solution. Also, if I change it in Mac OS X for my AirPort card, it just resets it at startup (as stated in the article). Anyway, when it crashed i started the sample command, the result are attached to this bug.

Thanks.
Comment 20 y.kalter 2007-07-12 10:12:20 PDT
I completely reinstalled my MacBook with Mac OS X 10.4.9 again today and installed no program after that to see if a 3rd party application was causing problems. But within 5 minutes of usage the problem occured again.

Thought i'd let you know.
Comment 21 David Kilzer (:ddkilzer) 2007-07-12 10:33:08 PDT
(In reply to comment #20)
> I completely reinstalled my MacBook with Mac OS X 10.4.9 again today and
> installed no program after that to see if a 3rd party application was causing
> problems. But within 5 minutes of usage the problem occured again.
> 
> Thought i'd let you know.

I'm running short on ideas for things to try next.

You said that if you use a wired connection, this NEVER happens?

Most routers (wireless or otherwise) have firmware updates available.  Have you tried going to the vendor's web site to check for a firmware update?  If there is one, you might consider installing it to see if that fixes the issue.

Comment 22 y.kalter 2007-07-12 11:58:28 PDT
(In reply to comment #21)
> (In reply to comment #20)
> > I completely reinstalled my MacBook with Mac OS X 10.4.9 again today and
> > installed no program after that to see if a 3rd party application was causing
> > problems. But within 5 minutes of usage the problem occured again.
> > 
> > Thought i'd let you know.
> 
> I'm running short on ideas for things to try next.
> 
> You said that if you use a wired connection, this NEVER happens?
> 
> Most routers (wireless or otherwise) have firmware updates available.  Have you
> tried going to the vendor's web site to check for a firmware update?  If there
> is one, you might consider installing it to see if that fixes the issue.
> 
I'm pretty sure it doesn't happen on a wired connection, as I have found a way to reproduce the problem, well for the most part. It occurs mostly when I empty Safari's cache, open the follwing URL http://gathering.tweakers.net/forum/list_messages/1224245/?limit=999 and let it load. Sometimes it won't hang, but most of the time it will. On which percentage is different. If I do the same in Camino it works great, except that it says that a script stopped responding. In Safari, this problem does not only occur on the website, sometimes it does the same at other websites with a decent amount of images. Sometimes even before an image is loaded.

My router is updated with the latest firmware update from Linksys, also tried a custom Tomato firmware. I may buy an Airport Extreme if that could fix the problem, but I read someone with that router has the same problem, so I don't know if I should buy that expensive (for me though) router.

Did the Safari Sample file show anything?

Thanks for yout help, I really appreciate it. 
Comment 23 David Kilzer (:ddkilzer) 2007-07-12 12:56:56 PDT
(In reply to comment #22)
> I'm pretty sure it doesn't happen on a wired connection, as I have found a way
> to reproduce the problem, well for the most part. It occurs mostly when I empty
> Safari's cache, open the follwing URL
> http://gathering.tweakers.net/forum/list_messages/1224245/?limit=999 and let it
> load. Sometimes it won't hang, but most of the time it will. On which
> percentage is different. If I do the same in Camino it works great, except that
> it says that a script stopped responding. In Safari, this problem does not only
> occur on the website, sometimes it does the same at other websites with a
> decent amount of images. Sometimes even before an image is loaded.

Please take a tcpdump of Safari loading the page with the error, then Camino loading the same page without the error.

> My router is updated with the latest firmware update from Linksys, also tried a
> custom Tomato firmware. I may buy an Airport Extreme if that could fix the
> problem, but I read someone with that router has the same problem, so I don't
> know if I should buy that expensive (for me though) router.

The Linksys router should work.

> Did the Safari Sample file show anything?

I haven't looked at it yet--will try to get to that later today.

Comment 24 David Kilzer (:ddkilzer) 2007-07-14 13:42:01 PDT
(In reply to comment #23)
> (In reply to comment #22)
> > Did the Safari Sample file show anything?
> I haven't looked at it yet--will try to get to that later today.

It shows Safari is hung, which we already knew.  :)  I don't have a lot of experience reviewing Safari sample logs, but it's plausible that Safari is simply waiting for the network layer to send it data to complete theh page load.

Since we've verified that there are network-related issues (see "TCP segment of a reassembled PDU" in Comment #14), I don't think this is a Safari issue.  I'm going to file a Radar bug for it, though, since someone else may be able to derive more information about the tcpdump than me.

Could you provide the following (in a private email if you prefer):
- Exact model of Linksys router.
- Firmware revision of Linksys router.
- Internet Service Provider you're using.

Per Comment #23, could you take another tcpdump of Safari and Camino again?  Thanks!

Comment 25 David Kilzer (:ddkilzer) 2007-07-14 13:42:29 PDT
<rdar://problem/5335699>
Comment 26 David Kilzer (:ddkilzer) 2007-07-14 13:46:04 PDT
Also, a System Profiler (*.spx) output from one or both of your Macs having issues would help.  (Please send those via private email.)

Comment 27 David Kilzer (:ddkilzer) 2007-07-14 14:02:11 PDT
(In reply to comment #22)
> (In reply to comment #21)
> > You said that if you use a wired connection, this NEVER happens?
> 
> I'm pretty sure it doesn't happen on a wired connection, as I have found a way
> to reproduce the problem, well for the most part.

Please try to reproduce the issue with a wired connection.  If we can be sure it doesn't happen on a wired connection, then that will further isolate the issue.

Also, does your wired connection go through the same wireless router, or does it bypass it?  (It would be beneficial to test both ways if possible.)

I just realized there is another test case we're missing.  Have you tried Safari 3.0 on Windows through the wireless connection?  I would be very interested if it exhibits the stalling behavior as well.

http://www.apple.com/safari/

Do you know if anyone else has similar issues on Macs with your current ISP?

(In reply to comment #24)
> Could you provide the following (in a private email if you prefer):
> - Exact model of Linksys router.
> - Firmware revision of Linksys router.

Oops, you said earlier that you tried a Netgear router, and it had the same issue, so it's probably not related to the Linksys router.  (If that is the case, though, I'd expect a wired connection to cause issues as well, unless introducing a router between your ISP and your Macs is causing an issue.)

Some more wireless router questions:
1. Are you using security on the wireless link (like WEP or WPA)?  If so, what kind?
2. Which wireless protocol are you connecting with (802.11 a/b/g)?  Do the Macs use the same protocol as the Windows systems?
3. Do you know if you're getting interference from another wireless network using your channel?  (For example, are there over 10 wireless networks that you see in the Airport menu on OS X?)

Sorry for all the questions--I'm trying to get to the bottom of this!

Comment 28 y.kalter 2007-07-15 04:01:52 PDT
> Could you provide the following (in a private email if you prefer):
> - Exact model of Linksys router.
> - Firmware revision of Linksys router.
> - Internet Service Provider you're using.
> 
> Per Comment #23, could you take another tcpdump of Safari and Camino again? 
> Thanks!
> 

Answered in a e-mail message.

>Also, a System Profiler (*.spx) output from one or both of your Macs having
>issues would help.  (Please send those via private email.)

Also answered in a e-mail message.

>Please try to reproduce the issue with a wired connection.  If we can be sure
>it doesn't happen on a wired connection, then that will further isolate the
>issue.

Been on the internet yesterday with a cable, and it occured once as far as I can remember. I will try to reproduce it again today, but it is alot harder to do that on a wired connection.

>Also, does your wired connection go through the same wireless router, or does
>it bypass it?  (It would be beneficial to test both ways if possible.)

I tested it through the router, but I realise I have the possibility to connect one computer directly to the modem. Will also try that today and report back on that later.

>I just realized there is another test case we're missing.  Have you tried
>Safari 3.0 on Windows through the wireless connection?  I would be very
>interested if it exhibits the stalling behavior as well.
>
>http://www.apple.com/safari/

Problem doesn't occur on Safari 3.0.2 beta for Windows on my dad's XP notebook.

>Do you know if anyone else has similar issues on Macs with your current ISP?

I'm sorry, I don't know that. I do know that some other people suffer from this problem aswell. For example:
http://forums.macrumors.com/showthread.php?t=307258
http://forums.macrumors.com/showthread.php?t=238911

>Some more wireless router questions:
>1. Are you using security on the wireless link (like WEP or WPA)?  If so, what
>kind?

WPA Personal TKIP. Also tried WPA2 TKIP, still have to try unsecure.

>2. Which wireless protocol are you connecting with (802.11 a/b/g)?  Do the Macs
>use the same protocol as the Windows systems?

802.11g, all the computers have g capable cards. Also tried the setting Wireless-Mode from Mixed to G-only and B-only, doesn't fix anything.

>3. Do you know if you're getting interference from another wireless network
>using your channel?  (For example, are there over 10 wireless networks that you
>see in the Airport menu on OS X?)

I've made some screenshots of iStumber.
iMac: http://members.home.nl/j.kalter/images/istumbler_imac.png
MacBook: http://members.home.nl/j.kalter/images/istumbler_macbook.png

I'm going to try a channel that is not occupied.

>Sorry for all the questions--I'm trying to get to the bottom of this!

No problem, i'm glad that someone wants to help me finding a solution! :-)
Comment 29 y.kalter 2007-07-15 05:00:23 PDT
> >Some more wireless router questions:
> >1. Are you using security on the wireless link (like WEP or WPA)?  If so, what
> >kind?
> 
> WPA Personal TKIP. Also tried WPA2 TKIP, still have to try unsecure.

Unsecure doesn't work.

> >3. Do you know if you're getting interference from another wireless network
> >using your channel?  (For example, are there over 10 wireless networks that you
> >see in the Airport menu on OS X?)
> 
> I've made some screenshots of iStumber.
> iMac: http://members.home.nl/j.kalter/images/istumbler_imac.png
> MacBook: http://members.home.nl/j.kalter/images/istumbler_macbook.png
> 
> I'm going to try a channel that is not occupied.
> 

Tried channel 3 (was 11), doesn't work.
Comment 30 y.kalter 2007-07-15 11:09:40 PDT
I can't seem to reproduce the problem when the computers are connected through a wire. With or without the Linksys. It seems to occur only when connected wireless.
Comment 31 David Kilzer (:ddkilzer) 2007-07-15 11:37:32 PDT
(In reply to comment #29)
> Unsecure doesn't work.
> Tried channel 3 (was 11), doesn't work.

By "doesn't work" I presume you mean that you're able to reproduce the issue (e.g., the issue still occurs).

Comment 32 y.kalter 2007-07-15 11:39:35 PDT
(In reply to comment #31)
> (In reply to comment #29)
> > Unsecure doesn't work.
> > Tried channel 3 (was 11), doesn't work.
> 
> By "doesn't work" I presume you mean that you're able to reproduce the issue
> (e.g., the issue still occurs).
> 

Yes, I meant that the issue still occurs (I'm Dutch and having some trouble explaining everything, sorry for that).
Comment 33 David Kilzer (:ddkilzer) 2007-07-15 11:42:43 PDT
Another question:  Does this occur with both Safari 2 and Safari 3?
Comment 34 David Kilzer (:ddkilzer) 2007-07-15 11:43:26 PDT
(In reply to comment #32)
> Yes, I meant that the issue still occurs (I'm Dutch and having some trouble
> explaining everything, sorry for that).

Your English is perfect...it's the English language that's ambiguous sometimes.  :)

Comment 35 y.kalter 2007-07-15 11:50:15 PDT
(In reply to comment #33)
> Another question:  Does this occur with both Safari 2 and Safari 3?
> 

The last time I installed Safari 3 (about one week ago) it happened within 5 minutes of usage.
Comment 36 Mark Rowe (bdash) 2007-07-15 12:02:23 PDT
So it happens with both Safari 2.0 and the Safari 3 beta?
Comment 37 y.kalter 2007-07-15 12:40:43 PDT
(In reply to comment #36)
> So it happens with both Safari 2.0 and the Safari 3 beta?
> 

I just installed Safari 3 to confirm this, but now I am unable to reproduce the problem. I swear this problem also occured in Safari 3, because I've tried that for over three times now. This problem is getting stranger by the day.
Comment 38 y.kalter 2007-07-15 13:14:43 PDT
Tested Safari 3 and I can say for sure now that Safari 3 also suffers from this problem. It was loading a thread on a forum and it hung.
Comment 39 y.kalter 2007-07-20 08:52:27 PDT
Hi,

Is there some news from Apple about this issue? It has been reported to Apple if I understand correctly?  I'm sorry if I come over to you as impatient, that was really not my intention.
Comment 40 y.kalter 2007-07-21 13:01:15 PDT
Hmm, something interesting. I've tried OmniWeb today and it already hung on me three times today exactly the same way Safari does. Although I'm not sure, I think it uses WebKit too (or a modified version)? I still don't have the problem in Camino.
Comment 41 David Kilzer (:ddkilzer) 2007-07-21 13:25:26 PDT
(In reply to comment #40)
> Hmm, something interesting. I've tried OmniWeb today and it already hung on me
> three times today exactly the same way Safari does. Although I'm not sure, I
> think it uses WebKit too (or a modified version)? I still don't have the
> problem in Camino.

OmniWeb uses both WebKit (slightly different version) and CFNetwork/Foundation libraries, just like Safari does, so I'm not surprised that it exhibits the issue.

Comment 42 David Kilzer (:ddkilzer) 2007-08-10 06:06:47 PDT
Closing as RESOLVED/INVALID since this issue is not in WebKit.  Will be tracked internally by radar.