Bug 14480 - Online maps on Yandex do not scroll
Summary: Online maps on Yandex do not scroll
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://maps.yandex.ru/moscow
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-06-30 10:57 PDT by Gennady
Modified: 2009-01-14 04:28 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gennady 2007-06-30 10:57:06 PDT
Can't scroll online maps on http://maps.yandex.ru/moscow making them unusable

To reproduce:
1. Enter http://maps.yandex.ru/moscow
2. Zoom in either by using zoom tool or sidebar
3. Select drag tool (hand) and try to click&drag on map

Expected behaviour: map should scroll following mouse pointer
Actual results: nothing happens

4. try clicking any one of arrows around the map 
Expected behaviour: map should shift to the selected side 
Actual results: map unzooms to original state and then shifts

notes:
all these work fine in Firefox and MSIE and have minor problems in some versions of Opera
drag tool did work fine in Safari 2.0.3 , while arrows also behaved erratically
Comment 1 Alexey Proskuryakov 2007-07-09 04:31:28 PDT
I think that (3) may have the same cause as bug 12110.

I have tried to reduce the pre-existing problem with arrows around the map (4), but didn't succeed yet.
Comment 2 Alexey Proskuryakov 2007-12-25 05:30:40 PST
Dragging with the mouse works now, but (4) is still a problem.
Comment 3 Alexey Proskuryakov 2009-01-14 04:28:05 PST
The site code has changed a lot since this bug was filed, and it works fine in Safari.