Bug 14441 - REPRODUCIBLE HANG: Gmail editor hangs on option-move
Summary: REPRODUCIBLE HANG: Gmail editor hangs on option-move
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Nobody
URL: http://mail.google.com/mail/
Keywords: HasReduction, InRadar
: 14471 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-27 20:07 PDT by Ryan Tarpine
Modified: 2007-07-23 15:23 PDT (History)
2 users (show)

See Also:


Attachments
Sample of hung Safari (19.08 KB, text/plain)
2007-07-05 22:24 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Tarpine 2007-06-27 20:07:26 PDT
Log into gmail
Click Compose Mail
Click in body text area
Press return once to make a new line
Hold option and then press left
While still holding the left key (and option), press right
Comment 1 David Kilzer (:ddkilzer) 2007-07-05 22:22:46 PDT
Confirmed with a local debug build of WebKit r24013 with Safari 3.0 (522.12) on Mac OS X 10.4.10 (8R218).

Comment 2 David Kilzer (:ddkilzer) 2007-07-05 22:24:03 PDT
Created attachment 15411 [details]
Sample of hung Safari

$ sample Safari 10 10 
Sampling process 10427 each 10 msecs 1000 times
Sample analysis of process 10427 written to file /tmp/Safari_10427.sample.txt
Comment 3 David Kilzer (:ddkilzer) 2007-07-05 22:24:33 PDT
<rdar://problem/5316344>
Comment 4 mitz 2007-07-06 00:29:14 PDT
*** Bug 14471 has been marked as a duplicate of this bug. ***
Comment 5 mitz 2007-07-06 00:31:12 PDT
Attachment 15321 [details] is a reduction: click at the top of the page to get a caret and press option-left arrow.
This is also <rdar://problem/5304772>.
Comment 6 David Kilzer (:ddkilzer) 2007-07-11 14:15:57 PDT
Works for me with a local debug build of WebKit r24117 on Safari 3.0 (522.12) on Mac OS X 10.4.10 (8R218).

Comment 7 Justin Garcia 2007-07-11 14:18:34 PDT
At least one of the duplicates,14471, still reproduces, so I'm leaving this open.
Comment 8 Justin Garcia 2007-07-11 14:35:20 PDT
I have a patch for 14471.
Comment 9 mitz 2007-07-23 15:19:06 PDT
Is this one still reproducible?
Comment 10 Justin Garcia 2007-07-23 15:23:41 PDT
Can't reproduce here, and 14471 is fixed.  Closing.