Bug 143732 - Correct layering violation in DumpRenderTree Build
Summary: Correct layering violation in DumpRenderTree Build
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords:
Depends on:
Blocks: 143684
  Show dependency treegraph
 
Reported: 2015-04-14 15:19 PDT by Brent Fulgham
Modified: 2015-04-14 16:48 PDT (History)
2 users (show)

See Also:


Attachments
Patch (5.73 KB, patch)
2015-04-14 16:02 PDT, Brent Fulgham
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2015-04-14 15:19:40 PDT
In Bug 143286, I introduced a layering violation between DumpRenderTree and WebCore. Instead of accessing WebCore types directly, DRT needs to pass through the WebCoreTestSupport library to manipulate WebCore state.
Comment 1 Brent Fulgham 2015-04-14 16:02:24 PDT
Created attachment 250750 [details]
Patch
Comment 2 Brent Fulgham 2015-04-14 16:48:58 PDT
Committed r182821: <http://trac.webkit.org/changeset/182821>