Bug 142833 - Web Inspector: Node Details Sidebar Properties Section has "undefined" for all prototype properties
Summary: Web Inspector: Node Details Sidebar Properties Section has "undefined" for al...
Status: RESOLVED DUPLICATE of bug 153911
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2015-03-18 12:35 PDT by Joseph Pecoraro
Modified: 2016-05-29 08:30 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2015-03-18 12:35:47 PDT
* SUMMARY
Node Details Sidebar Properties Section has "undefined" for all prototype properties.

The Properties Section makes bad assumptions that need to be fixed. Currently it gets Prototype property values on the Prototype object instead of on the actual original object. This it is always undefined unless it is a function.

Should this instead be an API view?
Comment 1 Timothy Hatcher 2015-03-18 15:54:26 PDT
Yes, I think it should be API view.
Comment 2 Brian Burg 2016-05-29 08:29:37 PDT
Forward-duping to newer bug that reflects current behavior. It has a radar too.

*** This bug has been marked as a duplicate of bug 153911 ***
Comment 3 Radar WebKit Bug Importer 2016-05-29 08:30:14 PDT
<rdar://problem/26535044>