Bug 142272 - [ARM] jsc-layout-tests.yaml/js/script-tests/array-from.js fails on Aarch64
Summary: [ARM] jsc-layout-tests.yaml/js/script-tests/array-from.js fails on Aarch64
Status: RESOLVED DUPLICATE of bug 208470
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 108645 141054
  Show dependency treegraph
 
Reported: 2015-03-04 02:39 PST by Csaba Osztrogonác
Modified: 2020-03-02 14:41 PST (History)
13 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Csaba Osztrogonác 2015-03-26 02:56:06 PDT
(In reply to comment #0)
> iOS - https://bugs.webkit.org/show_bug.cgi?id=141054#c19
> Linux - https://bugs.webkit.org/show_bug.cgi?id=141054#c20
> 
> Skipped on iOS by http://trac.webkit.org/changeset/180573

I'm going to skip it on Linux too to paint the bot green.

Dean, Michael, do we know why is this test fails on AArch64?
And is there any plan to fix it in the near future?
Comment 2 Michael Saboff 2015-03-26 07:58:52 PDT
(In reply to comment #1)
> (In reply to comment #0)
> > iOS - https://bugs.webkit.org/show_bug.cgi?id=141054#c19
> > Linux - https://bugs.webkit.org/show_bug.cgi?id=141054#c20
> > 
> > Skipped on iOS by http://trac.webkit.org/changeset/180573
> 
> I'm going to skip it on Linux too to paint the bot green.
> 
> Dean, Michael, do we know why is this test fails on AArch64?
> And is there any plan to fix it in the near future?

I see these tests flakey on both ARM32 and AArch64.  The last AArch64 failure that I can find though was at r180489.  ARM32 still fails intermittently.  I going to look at flakey tests in the next day or so.
Comment 3 Csaba Osztrogonác 2015-05-08 02:32:22 PDT
Just to document, I skipped on AArch64:
http://trac.webkit.org/changeset/182006/trunk/LayoutTests/js/script-tests/array-from.js

And it passes on our ARM32 bots always, we can't see any failure.
Comment 4 Joseph Pecoraro 2016-06-06 20:55:54 PDT
Hmm, this is concerning. Why would Array.from fail on arm64? This is also kinda old, so perhaps it works now.
Comment 5 Radar WebKit Bug Importer 2016-06-06 20:56:27 PDT
<rdar://problem/26666207>
Comment 6 Zan Dobersek 2017-10-18 02:44:39 PDT
This test currently passes on ARM64. Keeping this open until the skip directive is removed.
Comment 7 Zan Dobersek 2017-10-18 02:56:46 PDT
This failure isn't exhibited anymore. I'll close the bug once the skip directive is removed.
Comment 8 Saam Barati 2020-03-02 14:41:03 PST
Removing it in: 
https://bugs.webkit.org/show_bug.cgi?id=208470

*** This bug has been marked as a duplicate of bug 208470 ***