Bug 141128 - Shrink RenderBlock.
Summary: Shrink RenderBlock.
Status: RESOLVED DUPLICATE of bug 141129
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Andreas Kling
URL:
Keywords: Performance
Depends on:
Blocks:
 
Reported: 2015-01-31 16:44 PST by Andreas Kling
Modified: 2015-02-01 16:15 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kling 2015-01-31 16:44:09 PST
Looks like we can lose the line-height cache in RenderBlock without affecting any benchmarks, then the remaining bits fit into RenderElement's bitfield.
Savings potential: 8 bytes per RenderBlock (including subclasses)
Comment 1 Alexey Proskuryakov 2015-02-01 16:15:11 PST

*** This bug has been marked as a duplicate of bug 141129 ***