Bug 140877 - Leaks bot shouldn't run JSC tests
Summary: Leaks bot shouldn't run JSC tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-25 22:33 PST by Alexey Proskuryakov
Modified: 2015-01-26 10:18 PST (History)
7 users (show)

See Also:


Attachments
proposed patch (5.12 KB, patch)
2015-01-25 22:36 PST, Alexey Proskuryakov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2015-01-25 22:33:44 PST
JSC tests take 48 minutes on leaks bot, and do not even have leaks checking enabled.

I'm not quite sure why the tests are so much slower here than on other testers (the machine is weaker than others, but not by that much). In any case, there is no reason to run anything but layout tests on the leaks bot, the rest just duplicates what other testers do.
Comment 1 Alexey Proskuryakov 2015-01-25 22:36:44 PST
Created attachment 245327 [details]
proposed patch
Comment 2 WebKit Commit Bot 2015-01-26 10:18:10 PST
Comment on attachment 245327 [details]
proposed patch

Clearing flags on attachment: 245327

Committed r179122: <http://trac.webkit.org/changeset/179122>
Comment 3 WebKit Commit Bot 2015-01-26 10:18:14 PST
All reviewed patches have been landed.  Closing bug.