Bug 139375 - Inline elements whose parents have small line-height are laid out too low
Summary: Inline elements whose parents have small line-height are laid out too low
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-12-07 14:04 PST by Myles C. Maxfield
Modified: 2014-12-08 15:10 PST (History)
14 users (show)

See Also:


Attachments
Patch (362.48 KB, patch)
2014-12-07 14:12 PST, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-14 for mac-mountainlion-wk2 (540.13 KB, application/zip)
2014-12-07 15:14 PST, Build Bot
no flags Details
Patch (385.07 KB, patch)
2014-12-07 15:53 PST, Myles C. Maxfield
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2014-12-07 14:04:39 PST
Inline elements whose parents have small line-height are laid out too low
Comment 1 Myles C. Maxfield 2014-12-07 14:12:56 PST
Created attachment 242769 [details]
Patch
Comment 2 Myles C. Maxfield 2014-12-07 14:14:46 PST
<rdar://problem/19053991>
Comment 3 Radar WebKit Bug Importer 2014-12-07 14:15:10 PST
<rdar://problem/19170410>
Comment 4 Build Bot 2014-12-07 15:13:59 PST
Comment on attachment 242769 [details]
Patch

Attachment 242769 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5602963707920384

New failing tests:
fast/forms/search-vertical-alignment.html
Comment 5 Build Bot 2014-12-07 15:14:12 PST
Created attachment 242770 [details]
Archive of layout-test-results from webkit-ews-14 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-14  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 6 Myles C. Maxfield 2014-12-07 15:48:53 PST
Looks like fast/forms/search-vertical-alignment.html has different behavior on the EWS bots and my Yosemite machine
Comment 7 Myles C. Maxfield 2014-12-07 15:53:49 PST
Created attachment 242772 [details]
Patch
Comment 8 Myles C. Maxfield 2014-12-08 12:35:25 PST
<rdar://problem/19053991>
Comment 9 Dave Hyatt 2014-12-08 13:33:53 PST
Comment on attachment 242772 [details]
Patch

r=me
Comment 10 Dave Hyatt 2014-12-08 13:42:08 PST
I would consider changing the box-sizing test (2nd pixel result), since it does say all the boxes should look identical. Could be confusing for someone coming along later if they see the new results.
Comment 11 Myles C. Maxfield 2014-12-08 15:10:42 PST
http://trac.webkit.org/changeset/176978