Bug 139283 - Fix style sharing with the "type" and "readonly" attributes
Summary: Fix style sharing with the "type" and "readonly" attributes
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Benjamin Poulain
URL:
Keywords:
: 119000 123239 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-04 19:43 PST by Benjamin Poulain
Modified: 2015-02-01 18:03 PST (History)
4 users (show)

See Also:


Attachments
Patch (102.75 KB, patch)
2014-12-04 20:04 PST, Benjamin Poulain
koivisto: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2014-12-04 19:43:46 PST
Fix style sharing with the "type" and "readonly" attributes
Comment 1 Benjamin Poulain 2014-12-04 20:04:04 PST
Created attachment 242612 [details]
Patch
Comment 2 Benjamin Poulain 2014-12-04 20:14:16 PST
Comment on attachment 242612 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=242612&action=review

> Source/WebCore/css/RuleSet.cpp:105
> +static bool containsUncommonAttributeSelector(const CSSSelector& rootSelector, bool startsOnRightmostElement)

Before landing I should rename this boolean.

startsOnRightmostElement->matchesRightmostElement
Comment 3 Antti Koivisto 2014-12-05 12:50:43 PST
Comment on attachment 242612 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=242612&action=review

> Source/WebCore/css/RuleSet.cpp:111
> +            // It is a very aggressive solution which disable a lot of style sharing on pages that rely on attributes for styling.

seems more 'primitive' than 'aggressive'
Comment 4 Benjamin Poulain 2014-12-05 12:57:35 PST
Committed r176864: <http://trac.webkit.org/changeset/176864>
Comment 5 Benjamin Poulain 2015-02-01 17:58:38 PST
*** Bug 123239 has been marked as a duplicate of this bug. ***
Comment 6 Benjamin Poulain 2015-02-01 18:03:11 PST
*** Bug 119000 has been marked as a duplicate of this bug. ***