Bug 13872 - REGRESSION: An empty search field can have a cancel button
Summary: REGRESSION: An empty search field can have a cancel button
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-05-25 04:48 PDT by mitz
Modified: 2007-05-25 12:15 PDT (History)
0 users

See Also:


Attachments
Avoid sharing the cancel button style (18.78 KB, patch)
2007-05-25 04:51 PDT, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2007-05-25 04:48:44 PDT
Essentially the same problem as bug 13800: search fields may share the cancel button style, but they should not, because they mutate it independently of each other.

I have a patch that includes a test case.
Comment 1 mitz 2007-05-25 04:51:10 PDT
Created attachment 14718 [details]
Avoid sharing the cancel button style

Search fields use a few other pseudo element styles (for the results widget), but since they don't mutate them after creation, I don't see any risk in that.
Comment 2 Darin Adler 2007-05-25 08:06:28 PDT
Comment on attachment 14718 [details]
Avoid sharing the cancel button style

r=me
Comment 3 Sam Weinig 2007-05-25 12:15:59 PDT
Landed in r21767.