Bug 137697 - REGRESSION(r174567): [GTK] Layout Tests platform/gtk/accessibility/aria-table-hierarchy.html and platform/gtk/accessibility/table-hierarchy.html fail
Summary: REGRESSION(r174567): [GTK] Layout Tests platform/gtk/accessibility/aria-table...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Joanmarie Diggs (irc: joanie)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-14 09:34 PDT by Carlos Alberto Lopez Perez
Modified: 2014-10-14 12:30 PDT (History)
10 users (show)

See Also:


Attachments
Patch (7.50 KB, patch)
2014-10-14 10:52 PDT, Joanmarie Diggs (irc: joanie)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2014-10-14 09:34:24 PDT
The following 2 layout test are failing on platform GTK since r174567 <http://trac.webkit.org/r174567>

Regressions: Unexpected text-only failures (2)
  platform/gtk/accessibility/aria-table-hierarchy.html [ Failure ]
    * Diff: https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20(Tests)/r174567%20(3387)/platform/gtk/accessibility/aria-table-hierarchy-pretty-diff.html
  platform/gtk/accessibility/table-hierarchy.html [ Failure ]
    * Diff: https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20(Tests)/r174567%20(3387)/platform/gtk/accessibility/table-hierarchy-pretty-diff.html
Comment 1 Joanmarie Diggs (irc: joanie) 2014-10-14 09:55:38 PDT
This is a case where the tests need to be updated to reflect the new, and more accurate role mapping.
Comment 2 Carlos Alberto Lopez Perez 2014-10-14 10:20:11 PDT
I marked this two tests as failing on the GTK TestExpectations on r174685 <http://trac.webkit.org/r174685>.

Please remove them from the expectation file when fixing this bug.
Comment 3 Joanmarie Diggs (irc: joanie) 2014-10-14 10:52:45 PDT
Created attachment 239807 [details]
Patch
Comment 4 WebKit Commit Bot 2014-10-14 12:30:22 PDT
Comment on attachment 239807 [details]
Patch

Clearing flags on attachment: 239807

Committed r174697: <http://trac.webkit.org/changeset/174697>
Comment 5 WebKit Commit Bot 2014-10-14 12:30:26 PDT
All reviewed patches have been landed.  Closing bug.