Bug 137571 - Remove ENABLE_CSS3_CONDITIONAL_RULES
Summary: Remove ENABLE_CSS3_CONDITIONAL_RULES
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords:
: 116554 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-09 13:43 PDT by Dean Jackson
Modified: 2015-02-02 14:56 PST (History)
2 users (show)

See Also:


Attachments
Patch (67.42 KB, patch)
2014-10-09 14:38 PDT, Dean Jackson
no flags Details | Formatted Diff | Diff
Patch (67.37 KB, patch)
2014-10-09 14:47 PDT, Dean Jackson
no flags Details | Formatted Diff | Diff
Patch (62.92 KB, patch)
2014-10-09 15:05 PDT, Dean Jackson
no flags Details | Formatted Diff | Diff
Patch (67.08 KB, patch)
2014-10-09 15:14 PDT, Dean Jackson
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2014-10-09 13:43:35 PDT
Our support for @supports is pretty good (see https://bugs.webkit.org/show_bug.cgi?id=137569).

I think we should enable it everywhere, and thus remove the compile time guard.
Comment 1 Dean Jackson 2014-10-09 14:38:09 PDT
Created attachment 239571 [details]
Patch
Comment 2 Dean Jackson 2014-10-09 14:47:52 PDT
Created attachment 239573 [details]
Patch
Comment 3 Dean Jackson 2014-10-09 15:00:43 PDT
I'm not sure why the patch isn't applying. It works fine here.
Comment 4 Dean Jackson 2014-10-09 15:05:51 PDT
Created attachment 239575 [details]
Patch
Comment 5 Dean Jackson 2014-10-09 15:14:03 PDT
Created attachment 239576 [details]
Patch
Comment 6 Dean Jackson 2014-10-09 15:33:16 PDT
https://trac.webkit.org/r174536
Comment 7 Brent Fulgham 2015-02-02 14:55:33 PST
Comment on attachment 239576 [details]
Patch

It's interesting that the "skips" were removed from the WinCairo port, but no the actual Apple Windows port. I think these should be enabled on Apple Windows as well.
Comment 8 Brent Fulgham 2015-02-02 14:56:47 PST
*** Bug 116554 has been marked as a duplicate of this bug. ***