Bug 13683 - REGRESSION: Load never completes for nonexistent unqualified domain names
Summary: REGRESSION: Load never completes for nonexistent unqualified domain names
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
: 13750 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-11 15:39 PDT by Rachael Worthington (cheers)
Modified: 2007-05-16 22:17 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rachael Worthington (cheers) 2007-05-11 15:39:57 PDT
Steps to Reproduce:
1. launch the latest nightly.
2. attempt to load a URL that doesn't exist (I usually just keymash for 10 or so characters)
3. observe that the address bar enters the loading state and starts filling in then stops, and that the spinny activity circle keeps spinning indefinitely. No page is ever loaded.

From IRC: 
pewtermoose: clicking a link to download something  keeps the address bar in a loading state too
Comment 1 Brady Eidson 2007-05-11 15:46:52 PDT
Definitely introduced in the last nightly, or no?

Also, what is "the last nightly"?  time changes, you know  ;)
Comment 2 Rachael Worthington (cheers) 2007-05-11 16:07:35 PDT
apologies, although between  the timestamp you could probably have figured it out :P

from what i can tell using the nightlies to test, the bug was introduced between 21322 and 21368 at which point, I got distracted. 
Comment 3 Maciej Stachowiak 2007-05-12 01:14:37 PDT
Likely fallout from r21367.
Comment 4 Maciej Stachowiak 2007-05-12 01:20:20 PDT
It turns out that the key is unqualified domain names, not nonexistent pages. This shows the error page fine: nonexistent-domain-name.example.com

But typing just "nonexistent-domain-name" fails.
Comment 5 Brady Eidson 2007-05-16 14:45:00 PDT
*** Bug 13750 has been marked as a duplicate of this bug. ***
Comment 6 Brady Eidson 2007-05-16 14:45:55 PDT
<rdar://problem/5205162>
Comment 7 Maciej Stachowiak 2007-05-16 16:51:24 PDT
<rdar://problem/5205162>
Comment 8 Matt Lilek 2007-05-16 22:03:09 PDT
(In reply to comment #0)
> From IRC: 
> pewtermoose: clicking a link to download something  keeps the address bar in a
> loading state too
> 

Bug 13694
Comment 9 Matt Lilek 2007-05-16 22:17:06 PDT
Fix landed by Maciej in r21524