Bug 13655 - Incomplete repaint when text-shadow is used in a render layer with explicit height
Summary: Incomplete repaint when text-shadow is used in a render layer with explicit h...
Status: VERIFIED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P1 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-10 05:19 PDT by Timothy Hatcher
Modified: 2007-05-10 22:52 PDT (History)
1 user (show)

See Also:


Attachments
Test case (376 bytes, text/html)
2007-05-10 05:22 PDT, Timothy Hatcher
no flags Details
Test case using script (825 bytes, text/html)
2007-05-10 05:26 PDT, Timothy Hatcher
no flags Details
Simplify layer repaint logic (49.11 KB, patch)
2007-05-10 08:26 PDT, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2007-05-10 05:19:12 PDT
This was caused by the change to remove repaintObjectsBeforeLayout in bug 13496 (r21120 / http://trac.webkit.org/projects/webkit/changeset/21120).

See attached test case.
Comment 1 Timothy Hatcher 2007-05-10 05:22:55 PDT
Created attachment 14461 [details]
Test case
Comment 2 Timothy Hatcher 2007-05-10 05:26:34 PDT
Created attachment 14462 [details]
Test case using script
Comment 3 mitz 2007-05-10 08:26:49 PDT
Created attachment 14468 [details]
Simplify layer repaint logic

A P1/Critical bug is a good excuse to get rid of checkForRepaintOnResize.
Comment 4 Darin Adler 2007-05-10 10:26:02 PDT
Comment on attachment 14468 [details]
Simplify layer repaint logic

r=me
Comment 5 Timothy Hatcher 2007-05-10 22:12:17 PDT
Landed in r21390. http://trac.webkit.org/projects/webkit/changeset/21390
Comment 6 Timothy Hatcher 2007-05-10 22:52:27 PDT
This does fix my original document and the test case.