Bug 136311 - Web Replay: only generate EncodingTraits for enums defined in the target framework
Summary: Web Replay: only generate EncodingTraits for enums defined in the target fram...
Status: RESOLVED DUPLICATE of bug 136312
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brian Burg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-27 14:23 PDT by Brian Burg
Modified: 2015-01-18 23:02 PST (History)
3 users (show)

See Also:


Attachments
WIP (13.96 KB, patch)
2015-01-14 14:43 PST, Brian Burg
no flags Details | Formatted Diff | Diff
Proposed Fix (57.21 KB, patch)
2015-01-14 17:37 PST, Brian Burg
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2014-08-27 14:23:45 PDT
Currently it will unconditionally generate enum encoding traits if the enum is referenced in the Inputs.json file, even if it's from a different namespace and also in another framework's Inputs.json file.
Comment 1 Brian Burg 2015-01-14 14:43:55 PST
Created attachment 244639 [details]
WIP
Comment 2 Brian Burg 2015-01-14 17:37:46 PST
Created attachment 244668 [details]
Proposed Fix
Comment 3 WebKit Commit Bot 2015-01-14 17:40:17 PST
This patch modifies the WEB_REPLAY inputs generator. Please ensure that you have rebaselined any generator test results (i.e., by running `Tools/Scripts/run-input-generator-tests --reset-results`)
Comment 4 WebKit Commit Bot 2015-01-14 17:40:27 PST
Attachment 244668 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/replay/scripts/CodeGeneratorReplayInputs.py:785:  whitespace before '}'  [pep8/E202] [5]
ERROR: Source/JavaScriptCore/replay/scripts/tests/expected/generate-enum-encoding-helpers-with-guarded-values.json-TestReplayInputs.h:60:  The parameter name "button" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/replay/scripts/tests/expected/generate-enum-encoding-helpers.json-TestReplayInputs.h:81:  The parameter name "button" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/replay/scripts/tests/expected/generate-enum-with-guard.json-TestReplayInputs.h:71:  The parameter name "phase" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 4 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Brian Burg 2015-01-18 23:00:28 PST
Will fix these in one patch, since enums and inputs require similar filtering.

*** This bug has been marked as a duplicate of bug 136312 ***