Bug 136160 - Web Inspector: Fix CodeMirrorTokenTrackingController::_startTracking assertion
Summary: Web Inspector: Fix CodeMirrorTokenTrackingController::_startTracking assertion
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Saam Barati
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-08-22 10:39 PDT by Saam Barati
Modified: 2014-08-26 17:53 PDT (History)
5 users (show)

See Also:


Attachments
patch (618 bytes, patch)
2014-08-22 10:40 PDT, Saam Barati
timothy: review+
timothy: commit-queue-
Details | Formatted Diff | Diff
patch (567 bytes, patch)
2014-08-22 10:42 PDT, Saam Barati
no flags Details | Formatted Diff | Diff
patch (1.46 KB, patch)
2014-08-26 17:15 PDT, Saam Barati
no flags Details | Formatted Diff | Diff
patch (1.46 KB, patch)
2014-08-26 17:16 PDT, Saam Barati
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2014-08-22 10:39:00 PDT
This assertion fires often, but it doesn't indicate any kind of noteworthy error. 

_startTracking should either remove its assert if it wants to allow those that call it to call it regardless of if it's already tracking, or those that call _startTracking should only call it if _tracking is false.
Comment 1 Radar WebKit Bug Importer 2014-08-22 10:39:24 PDT
<rdar://problem/18103437>
Comment 2 Saam Barati 2014-08-22 10:40:54 PDT
Created attachment 236990 [details]
patch

I think this is the cause of the assertion constantly firing.
Comment 3 Saam Barati 2014-08-22 10:42:13 PDT
Created attachment 236991 [details]
patch

And this is another solution.
Comment 4 Timothy Hatcher 2014-08-23 09:00:34 PDT
That assert is pretty annoying. I think _mouseEntered should check.
Comment 5 Saam Barati 2014-08-23 19:17:13 PDT
(In reply to comment #4)
> That assert is pretty annoying. I think _mouseEntered should check.

I agree. I'll submit a patch to do this.
Comment 6 Saam Barati 2014-08-26 17:15:37 PDT
Created attachment 237187 [details]
patch
Comment 7 Saam Barati 2014-08-26 17:16:16 PDT
Created attachment 237188 [details]
patch
Comment 8 WebKit Commit Bot 2014-08-26 17:53:04 PDT
Comment on attachment 237188 [details]
patch

Clearing flags on attachment: 237188

Committed r172991: <http://trac.webkit.org/changeset/172991>
Comment 9 WebKit Commit Bot 2014-08-26 17:53:07 PDT
All reviewed patches have been landed.  Closing bug.