Bug 13554 - className change wont cause a repaint in a special case
Summary: className change wont cause a repaint in a special case
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-30 18:47 PDT by Timothy Hatcher
Modified: 2008-03-24 16:02 PDT (History)
2 users (show)

See Also:


Attachments
Test case. (1.36 KB, text/html)
2007-04-30 18:48 PDT, Timothy Hatcher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2007-04-30 18:47:34 PDT
While working on a Web Inspector change I ran into this bug.

Changing a className between two elements with a mousedown on one element removes the className value on another element. The other element will not repaint when it's className is removed. This only happens when mousedown, -webkit-user-select: none, background-image and font-weight: bold are used together. If you change or remove any of those elemnts, this bug goes away. For example, removing -webkit-user-select: none fixes this. Removing either bold or background-image fixes this. Changing background-image to just a background color also fixes this.

See attached test case.
Comment 1 Timothy Hatcher 2007-04-30 18:48:46 PDT
Created attachment 14278 [details]
Test case.

Test case showing the bug.
Comment 2 Timothy Hatcher 2007-04-30 18:50:13 PDT
I have seen this in Drosera before too, I just never could create a "simple" test case.
Comment 3 Dave Hyatt 2007-04-30 19:37:40 PDT
Probably a style sharing bug and/or some bug where something is missing from the diff method of RenderStyles.
Comment 4 Dave Hyatt 2007-04-30 19:53:12 PDT
This does not reproduce for me in 2.0 or ToT on Tiger.
Comment 5 Timothy Hatcher 2007-04-30 20:08:34 PDT
I am able to reproduce on TOT on Leopard. I will file a radar to track this.
Comment 6 Timothy Hatcher 2007-06-05 15:55:33 PDT
I have seen this bug before in Drosera on Tiger but was never able to find a reproducible case. The original test here was Leopard only.
Comment 7 Timothy Hatcher 2007-06-05 15:56:14 PDT
I have seen this bug before in Drosera on Tiger but was never able to find a reproducible case. The original test here was Leopard only.
Comment 8 mitz 2008-03-24 16:02:41 PDT
I cannot reproduce the bug in TOT on Leopard. IIRC, it turned out to be a Leopard bug.