[iOS WK2] WKWebView sometime tries to change the size of a null DrawingAreaProxy
Created attachment 235639 [details] Patch
Attachment 235639 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:2241: The parameter name "drawingArea" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 1 in 2 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 235639 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=235639&action=review > Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:1354 > + if (WebKit::DrawingAreaProxy* drawingArea = _page->drawingArea()) Aren't we in the WebKit namespace here? > Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:2241 > + if (WebKit::DrawingAreaProxy* drawingArea = _page->drawingArea()) Ditto.
Comment on attachment 235639 [details] Patch Clearing flags on attachment: 235639 Committed r171709: <http://trac.webkit.org/changeset/171709>
All reviewed patches have been landed. Closing bug.