Bug 135355 - Should not export symbols for base64Encode inline adapter methods
Summary: Should not export symbols for base64Encode inline adapter methods
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Template Framework (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-28 14:36 PDT by Brian Burg
Modified: 2014-07-28 14:47 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2014-07-28 14:36:16 PDT
(separate bug for root cause of 32bit build break)

Looking at Base64.h, there are 4 adapters and 2 actual implementations, but all are marked WTF_EXPORT_PRIVATE. Since EncodedValue.h is included multiple places, it will trigger weak symbol problems that seem to have been latent in that header.
Comment 1 Brian Burg 2014-07-28 14:47:51 PDT
Committed r171696: <http://trac.webkit.org/changeset/171696>