Bug 134861 - REGRESSION(r171034) [GTK] Build broken.
Summary: REGRESSION(r171034) [GTK] Build broken.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-12 17:16 PDT by Javier Fernandez
Modified: 2014-07-12 18:10 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.46 KB, patch)
2014-07-12 17:18 PDT, Javier Fernandez
no flags Details | Formatted Diff | Diff
Patch (2.45 KB, patch)
2014-07-12 17:26 PDT, Javier Fernandez
no flags Details | Formatted Diff | Diff
Patch (3.24 KB, patch)
2014-07-12 17:43 PDT, Javier Fernandez
no flags Details | Formatted Diff | Diff
Patch (2.40 KB, patch)
2014-07-12 17:54 PDT, Javier Fernandez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Javier Fernandez 2014-07-12 17:16:03 PDT
GTK Build was broken due to r171034 <http://trac.webkit.org/r171034>
Comment 1 Javier Fernandez 2014-07-12 17:18:35 PDT
Created attachment 234814 [details]
Patch
Comment 2 WebKit Commit Bot 2014-07-12 17:21:23 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Javier Fernandez 2014-07-12 17:26:48 PDT
Created attachment 234815 [details]
Patch
Comment 4 Darin Adler 2014-07-12 17:38:19 PDT
Comment on attachment 234815 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=234815&action=review

> Source/WebKit2/UIProcess/API/gtk/PageClientImpl.cpp:395
> +void PageClientImpl::navigationGestureWillEnd(bool willNavigate, WebBackForwardListItem&)
> +{
> +}
> +
> +void PageClientImpl::navigationGestureDidEnd(bool willNavigate, WebBackForwardListItem&)
> +{
> +}

Should omit argument names here to avoid unused argument warnings.
Comment 5 Javier Fernandez 2014-07-12 17:43:12 PDT
Created attachment 234816 [details]
Patch
Comment 6 Javier Fernandez 2014-07-12 17:54:07 PDT
Created attachment 234818 [details]
Patch
Comment 7 WebKit Commit Bot 2014-07-12 18:10:17 PDT
Comment on attachment 234818 [details]
Patch

Clearing flags on attachment: 234818

Committed r171040: <http://trac.webkit.org/changeset/171040>
Comment 8 WebKit Commit Bot 2014-07-12 18:10:21 PDT
All reviewed patches have been landed.  Closing bug.